summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorMark Asselstine <mark.asselstine@windriver.com>2023-04-07 19:36:01 -0400
committerRichard Purdie <richard.purdie@linuxfoundation.org>2023-04-13 11:55:40 +0100
commitc50135a3893d8bb7736b0ab34d960026fbbc7012 (patch)
treed4ccc81870b3d6d0833ababba2b2a2632e92cab9
parent3e585e41f561aab73685290631f2263795f571b9 (diff)
downloadopenembedded-core-contrib-c50135a3893d8bb7736b0ab34d960026fbbc7012.tar.gz
python3-psutil: fix-up -tests runtime dependencies
The psutil.tests module makes use of gcc, other tools and a minimal set of headers and build tools. If these are missing you will see ====================================================================== ERROR: psutil.tests.test_process.TestProcess.test_weird_environ ---------------------------------------------------------------------- Traceback (most recent call last): File "./psutil/tests/test_process.py", line 1452, in test_weird_environ create_exe(path, c_code=code) File "./psutil/tests/__init__.py", line 831, in create_exe raise ValueError("gcc is not installed") ValueError: gcc is not installed along with other errors related to the missing tools and headers. Add the missing RDEPENDS for the -tests package such that simply adding the -tests package to an image will be all that is needed. Signed-off-by: Mark Asselstine <mark.asselstine@windriver.com> Signed-off-by: Alexandre Belloni <alexandre.belloni@bootlin.com>
-rw-r--r--meta/recipes-devtools/python/python3-psutil_5.9.4.bb14
1 files changed, 14 insertions, 0 deletions
diff --git a/meta/recipes-devtools/python/python3-psutil_5.9.4.bb b/meta/recipes-devtools/python/python3-psutil_5.9.4.bb
index 54d5784a0d..c0977c74d3 100644
--- a/meta/recipes-devtools/python/python3-psutil_5.9.4.bb
+++ b/meta/recipes-devtools/python/python3-psutil_5.9.4.bb
@@ -24,4 +24,18 @@ RDEPENDS:${PN} += " \
${PYTHON_PN}-resource \
"
+RDEPENDS:${PN}-tests += " \
+ ${PN} \
+ ${PYTHON_PN} \
+ coreutils \
+ procps \
+ binutils \
+ gcc \
+ gcc-symlinks \
+ libstdc++ \
+ libstdc++-dev \
+"
+
+INSANE_SKIP:${PN}-tests += "dev-deps"
+
BBCLASSEXTEND = "native nativesdk"