aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRichard Purdie <richard.purdie@linuxfoundation.org>2012-11-19 22:16:22 +0000
committerMarcin Juszkiewicz <marcin.juszkiewicz@linaro.org>2012-11-29 12:00:35 +0100
commitd23e02ad4030618ce4141d6ddefff0879aee8095 (patch)
treeb5f0c915e72a2b6dd254e785f7b940a2165586eb
parent70774cd55d768fb07c85807ef03410b361d78c57 (diff)
downloadopenembedded-core-contrib-d23e02ad4030618ce4141d6ddefff0879aee8095.tar.gz
ldconfig/cdrtools/icecc-create-env/linuxdoc-tools/python: Set FILESPATH to find -native files
In a small number of cases we need to have ${PN} in FILESPATH rather than ${BPN}. Rather than hurt readability for all other recipes, set FILESPATH in these recipes so we can prune the default. Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
-rw-r--r--meta/recipes-core/eglibc/ldconfig-native_2.12.1.bb2
-rw-r--r--meta/recipes-devtools/cdrtools/cdrtools-native_2.01.bb2
-rw-r--r--meta/recipes-devtools/icecc-create-env/icecc-create-env-native_0.1.bb2
-rw-r--r--meta/recipes-devtools/linuxdoc-tools/linuxdoc-tools-native_0.9.66.bb2
-rw-r--r--meta/recipes-devtools/python/python-native_2.7.3.bb2
5 files changed, 10 insertions, 0 deletions
diff --git a/meta/recipes-core/eglibc/ldconfig-native_2.12.1.bb b/meta/recipes-core/eglibc/ldconfig-native_2.12.1.bb
index 2a939132b8..63ef95b7e7 100644
--- a/meta/recipes-core/eglibc/ldconfig-native_2.12.1.bb
+++ b/meta/recipes-core/eglibc/ldconfig-native_2.12.1.bb
@@ -14,6 +14,8 @@ SRC_URI = "file://ldconfig-native-2.12.1.tar.bz2 \
PR = "r2"
+FILESPATH = "${FILE_DIRNAME}/${PN}-${PV}/"
+
inherit native
S = "${WORKDIR}/${PN}-${PV}"
diff --git a/meta/recipes-devtools/cdrtools/cdrtools-native_2.01.bb b/meta/recipes-devtools/cdrtools/cdrtools-native_2.01.bb
index 9068771bc4..fc479774d9 100644
--- a/meta/recipes-devtools/cdrtools/cdrtools-native_2.01.bb
+++ b/meta/recipes-devtools/cdrtools/cdrtools-native_2.01.bb
@@ -20,6 +20,8 @@ inherit native
STAGE_TEMP = "${WORKDIR}/image-temp"
+FILESPATH = "${FILE_DIRNAME}/cdrtools-native/"
+
do_install() {
install -d ${STAGE_TEMP}
make install INS_BASE=${STAGE_TEMP}
diff --git a/meta/recipes-devtools/icecc-create-env/icecc-create-env-native_0.1.bb b/meta/recipes-devtools/icecc-create-env/icecc-create-env-native_0.1.bb
index 7db39781ee..b04474efcb 100644
--- a/meta/recipes-devtools/icecc-create-env/icecc-create-env-native_0.1.bb
+++ b/meta/recipes-devtools/icecc-create-env/icecc-create-env-native_0.1.bb
@@ -11,6 +11,8 @@ PR = "r2"
DEPENDS = ""
INHIBIT_DEFAULT_DEPS = "1"
+FILESPATH = "${FILE_DIRNAME}/${PN}/"
+
inherit native
PATCHTOOL = "patch"
diff --git a/meta/recipes-devtools/linuxdoc-tools/linuxdoc-tools-native_0.9.66.bb b/meta/recipes-devtools/linuxdoc-tools/linuxdoc-tools-native_0.9.66.bb
index fafa42194d..5c9dd6f5da 100644
--- a/meta/recipes-devtools/linuxdoc-tools/linuxdoc-tools-native_0.9.66.bb
+++ b/meta/recipes-devtools/linuxdoc-tools/linuxdoc-tools-native_0.9.66.bb
@@ -17,6 +17,8 @@ SRC_URI = "${DEBIAN_MIRROR}/main/l/linuxdoc-tools/linuxdoc-tools_${PV}.tar.gz \
SRC_URI[md5sum] = "f214e79b0dd084689cd04f18722bd563"
SRC_URI[sha256sum] = "128cabb52ef8fb2f370ee488ea92bf4d8e49859200c7c8cae807abfe860a62ec"
+FILESPATH = "${FILE_DIRNAME}/linuxdoc-tools-native/"
+
inherit autotools native
do_configure () {
diff --git a/meta/recipes-devtools/python/python-native_2.7.3.bb b/meta/recipes-devtools/python/python-native_2.7.3.bb
index b0b3503ed9..162ecedb73 100644
--- a/meta/recipes-devtools/python/python-native_2.7.3.bb
+++ b/meta/recipes-devtools/python/python-native_2.7.3.bb
@@ -19,6 +19,8 @@ SRC_URI += "file://04-default-is-optimized.patch \
"
S = "${WORKDIR}/Python-${PV}"
+FILESPATH = "${FILE_DIRNAME}/python-native/:${FILE_DIRNAME}/python/"
+
inherit native
RPROVIDES += "python-distutils-native python-compression-native python-textutils-native python-core-native"