aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorKoen Kooi <koen@dominion.thruhere.net>2011-04-28 10:14:58 +0200
committerKoen Kooi <koen@dominion.thruhere.net>2011-04-28 10:14:58 +0200
commit7bcba149f05cc9c5d8ce956ee40e2c6849601470 (patch)
treeee34e0fca50c53e6fa64310a50ca02f1f307da70
parentdb0c52ea9269d01a8ea7cb4d5d77ce51328f88ef (diff)
downloadopenembedded-core-contrib-7bcba149f05cc9c5d8ce956ee40e2c6849601470.tar.gz
linux-omap-psp 2.6.32: work around https://bugzilla.kernel.org/show_bug.cgi?id=11475
See http://lists.linuxtogo.org/pipermail/openembedded-core/2011-April/001559.html for some background on this issue Signed-off-by: Koen Kooi <koen@dominion.thruhere.net>
-rw-r--r--recipes-bsp/linux/linux-omap-psp_2.6.32.bb10
1 files changed, 10 insertions, 0 deletions
diff --git a/recipes-bsp/linux/linux-omap-psp_2.6.32.bb b/recipes-bsp/linux/linux-omap-psp_2.6.32.bb
index 3eca11ae3e..368872cfbb 100644
--- a/recipes-bsp/linux/linux-omap-psp_2.6.32.bb
+++ b/recipes-bsp/linux/linux-omap-psp_2.6.32.bb
@@ -185,7 +185,17 @@ do_install_perf() {
:
}
+do_install_prepend() {
+ mkdir headerstash -p
+ cp include/linux/bounds.h headerstash/
+ cp include/asm-arm/asm-offsets.h headerstash/
+}
+
do_install_append() {
+ cp headerstash/bounds.h $kerneldir/include/linux/
+ cp headerstash/asm-offsets.h $kerneldir/include/asm-arm/asm-offsets.h
+ rm -rf headerstash/
+
install -d ${D}/boot
install -m 0644 Documentation/arm/OMAP/DSS ${D}/boot/
}