aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorDmitry Rozhkov <dmitry.rozhkov@intel.com>2016-01-13 10:43:12 +0200
committerRichard Purdie <richard.purdie@linuxfoundation.org>2016-01-18 11:47:07 +0000
commit2b92f88c9e2112456f7e24e1506d2c76bd8f81d8 (patch)
tree074a446b1256ea8e9865d3f0fcd757d236d09b41
parente246905bfc271d271c9dbfb3dd78db53b36b849a (diff)
downloadopenembedded-core-contrib-2b92f88c9e2112456f7e24e1506d2c76bd8f81d8.tar.gz
libarchive: Add bsdtar and bsdcpio packages
Some products might need to use a tar replacement that 1. supports xattrs and 2. has more permissive license than GNU tar. And the bsdtar binary produced from libarchive meets these requirements. (From OE-Core rev: ebf68926139ae5374c4d2669930d7f3817ad8f5a) Signed-off-by: Dmitry Rozhkov <dmitry.rozhkov@intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
-rw-r--r--meta/recipes-extended/libarchive/libarchive_3.1.2.bb18
1 files changed, 17 insertions, 1 deletions
diff --git a/meta/recipes-extended/libarchive/libarchive_3.1.2.bb b/meta/recipes-extended/libarchive/libarchive_3.1.2.bb
index 716db9aff0..202507d64c 100644
--- a/meta/recipes-extended/libarchive/libarchive_3.1.2.bb
+++ b/meta/recipes-extended/libarchive/libarchive_3.1.2.bb
@@ -39,7 +39,7 @@ SRC_URI = "http://libarchive.org/downloads/libarchive-${PV}.tar.gz \
SRC_URI[md5sum] = "efad5a503f66329bb9d2f4308b5de98a"
SRC_URI[sha256sum] = "eb87eacd8fe49e8d90c8fdc189813023ccc319c5e752b01fb6ad0cc7b2c53d5e"
-inherit autotools lib_package pkgconfig
+inherit autotools update-alternatives pkgconfig
CPPFLAGS += "-I${WORKDIR}/extra-includes"
@@ -50,4 +50,20 @@ do_configure_prepend() {
cp -R ${STAGING_INCDIR_NATIVE}/ext2fs ${WORKDIR}/extra-includes/
}
+ALTERNATIVE_PRIORITY = "100"
+
+PACKAGES =+ "bsdtar"
+FILES_bsdtar = "${bindir}/bsdtar"
+
+ALTERNATIVE_bsdtar = "tar"
+ALTERNATIVE_LINK_NAME[tar] = "${base_bindir}/tar"
+ALTERNATIVE_TARGET[tar] = "${bindir}/bsdtar"
+
+PACKAGES =+ "bsdcpio"
+FILES_bsdcpio = "${bindir}/bsdcpio"
+
+ALTERNATIVE_bsdcpio = "cpio"
+ALTERNATIVE_LINK_NAME[cpio] = "${base_bindir}/cpio"
+ALTERNATIVE_TARGET[cpio] = "${bindir}/bsdcpio"
+
BBCLASSEXTEND = "native nativesdk"