aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorDaniel McGregor <daniel.mcgregor@vecima.com>2016-01-14 14:47:04 -0600
committerRichard Purdie <richard.purdie@linuxfoundation.org>2016-01-19 17:37:34 +0000
commit27c39c469ef006ff66fc013dd8aa2458a6a01940 (patch)
tree4de172dd707597dda6af61d44d0b5b4cc9f7e506
parent77fde15551e76a8473b19ed3cd032bd15c493615 (diff)
downloadopenembedded-core-contrib-27c39c469ef006ff66fc013dd8aa2458a6a01940.tar.gz
opkg-utils: store alternatives in nonarch_libdir
opkg-utils-native stores alternative info in /usr/lib, so do the same on the target. (From OE-Core rev: 0afe5f74337dbfd302c221bf3c0fa9a22e6e7987) Signed-off-by: Daniel McGregor <daniel.mcgregor@vecima.com> Signed-off-by: Ross Burton <ross.burton@intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
-rw-r--r--meta/recipes-devtools/opkg-utils/opkg-utils_git.bb2
1 files changed, 1 insertions, 1 deletions
diff --git a/meta/recipes-devtools/opkg-utils/opkg-utils_git.bb b/meta/recipes-devtools/opkg-utils/opkg-utils_git.bb
index b242d1f3fb..1bc561c08a 100644
--- a/meta/recipes-devtools/opkg-utils/opkg-utils_git.bb
+++ b/meta/recipes-devtools/opkg-utils/opkg-utils_git.bb
@@ -34,7 +34,7 @@ do_install() {
do_install_append_class-target() {
if [ -e "${D}${bindir}/update-alternatives" ]; then
- sed -i ${D}${bindir}/update-alternatives -e 's,/usr/bin,${bindir},g; s,/usr/lib,${libdir},g'
+ sed -i ${D}${bindir}/update-alternatives -e 's,/usr/bin,${bindir},g; s,/usr/lib,${nonarch_libdir},g'
fi
}