aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorBruce Ashfield <bruce.ashfield@windriver.com>2016-03-10 17:01:23 -0500
committerRichard Purdie <richard.purdie@linuxfoundation.org>2016-03-12 22:11:46 +0000
commite2fe28cdeee3c399012b36bab1f8460bc3452518 (patch)
tree37ae48762c519790df80fc3eb14b8db2d6e549cf
parent3d45853eef1269b455d840a60491802251368378 (diff)
downloadopenembedded-core-contrib-e2fe28cdeee3c399012b36bab1f8460bc3452518.tar.gz
linux-yocto/4.4: gpio-pca953x: add "drive" property
Integrating the following commit for the 4.4 kernel: [ gpio-pca953x: add "drive" property Galileo gen 2 has support for setting GPIO modes. Expose these properties through the GPIO sysfs interface. This approach is bit hacky, since it changes the interface semantics. The original patch was by Josef Ahmad <josef.ahmad@linux.intel.com> and made on top of kernel 3.8. ] (From OE-Core rev: 7256e5a9dba0652fe8361f3143771cb6371568b5) Signed-off-by: Saul Wold <sgw@linux.intel.com> Signed-off-by: Bruce Ashfield <bruce.ashfield@windriver.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
-rw-r--r--meta/recipes-kernel/linux/linux-yocto-rt_4.4.bb4
-rw-r--r--meta/recipes-kernel/linux/linux-yocto-tiny_4.4.bb4
-rw-r--r--meta/recipes-kernel/linux/linux-yocto_4.4.bb18
3 files changed, 13 insertions, 13 deletions
diff --git a/meta/recipes-kernel/linux/linux-yocto-rt_4.4.bb b/meta/recipes-kernel/linux/linux-yocto-rt_4.4.bb
index 268e21501d..2faad1d574 100644
--- a/meta/recipes-kernel/linux/linux-yocto-rt_4.4.bb
+++ b/meta/recipes-kernel/linux/linux-yocto-rt_4.4.bb
@@ -2,8 +2,8 @@ KBRANCH ?= "standard/preempt-rt"
require recipes-kernel/linux/linux-yocto.inc
-SRCREV_machine ?= "e9c6f8ed73f9200b0a134ed473b4246d8cba0c3f"
-SRCREV_meta ?= "0ae928f7664c97fcce9411a6323ee9b376a59996"
+SRCREV_machine ?= "dfa88200087a7ef73741383c05c14ff2f3978947"
+SRCREV_meta ?= "ce5b35bc76bb65d93d0897535c088f51dae4048b"
SRC_URI = "git://git.yoctoproject.org/linux-yocto-4.4.git;branch=${KBRANCH};name=machine \
git://git.yoctoproject.org/yocto-kernel-cache;type=kmeta;name=meta;branch=yocto-4.4;destsuffix=${KMETA}"
diff --git a/meta/recipes-kernel/linux/linux-yocto-tiny_4.4.bb b/meta/recipes-kernel/linux/linux-yocto-tiny_4.4.bb
index dc439e954f..8a6e921647 100644
--- a/meta/recipes-kernel/linux/linux-yocto-tiny_4.4.bb
+++ b/meta/recipes-kernel/linux/linux-yocto-tiny_4.4.bb
@@ -9,8 +9,8 @@ LINUX_VERSION ?= "4.4.3"
KMETA = "kernel-meta"
KCONF_BSP_AUDIT_LEVEL = "2"
-SRCREV_machine ?= "66009f8977a62d3bd29d4b89a8e29d1095524aea"
-SRCREV_meta ?= "0ae928f7664c97fcce9411a6323ee9b376a59996"
+SRCREV_machine ?= "3d2455f9da30f923c6bd69014fad4cc4ea738be6"
+SRCREV_meta ?= "ce5b35bc76bb65d93d0897535c088f51dae4048b"
PV = "${LINUX_VERSION}+git${SRCPV}"
diff --git a/meta/recipes-kernel/linux/linux-yocto_4.4.bb b/meta/recipes-kernel/linux/linux-yocto_4.4.bb
index 39b43e4d2f..d410b7c104 100644
--- a/meta/recipes-kernel/linux/linux-yocto_4.4.bb
+++ b/meta/recipes-kernel/linux/linux-yocto_4.4.bb
@@ -11,15 +11,15 @@ KBRANCH_qemux86 ?= "standard/base"
KBRANCH_qemux86-64 ?= "standard/base"
KBRANCH_qemumips64 ?= "standard/mti-malta64"
-SRCREV_machine_qemuarm ?= "9ae4dd8747fc85511ebc4b460dd5cc5049abd9c9"
-SRCREV_machine_qemuarm64 ?= "66009f8977a62d3bd29d4b89a8e29d1095524aea"
-SRCREV_machine_qemumips ?= "9f0cb8fa7b1b3e167bb8d70a3433246830ada786"
-SRCREV_machine_qemuppc ?= "66009f8977a62d3bd29d4b89a8e29d1095524aea"
-SRCREV_machine_qemux86 ?= "66009f8977a62d3bd29d4b89a8e29d1095524aea"
-SRCREV_machine_qemux86-64 ?= "66009f8977a62d3bd29d4b89a8e29d1095524aea"
-SRCREV_machine_qemumips64 ?= "d941e61b3aadae55344addb8bbb778a0c72087bc"
-SRCREV_machine ?= "66009f8977a62d3bd29d4b89a8e29d1095524aea"
-SRCREV_meta ?= "0ae928f7664c97fcce9411a6323ee9b376a59996"
+SRCREV_machine_qemuarm ?= "861adc8d32fbb0c1f14fb9b7b67222ab711473a1"
+SRCREV_machine_qemuarm64 ?= "3d2455f9da30f923c6bd69014fad4cc4ea738be6"
+SRCREV_machine_qemumips ?= "0b21ee5897cc49c94f42fca9cea4665f76ae7e0e"
+SRCREV_machine_qemuppc ?= "3d2455f9da30f923c6bd69014fad4cc4ea738be6"
+SRCREV_machine_qemux86 ?= "3d2455f9da30f923c6bd69014fad4cc4ea738be6"
+SRCREV_machine_qemux86-64 ?= "3d2455f9da30f923c6bd69014fad4cc4ea738be6"
+SRCREV_machine_qemumips64 ?= "8b25338045fdb88a9cdff808003102643f03083e"
+SRCREV_machine ?= "3d2455f9da30f923c6bd69014fad4cc4ea738be6"
+SRCREV_meta ?= "ce5b35bc76bb65d93d0897535c088f51dae4048b"
SRC_URI = "git://git.yoctoproject.org/linux-yocto-4.4.git;name=machine;branch=${KBRANCH}; \
git://git.yoctoproject.org/yocto-kernel-cache;type=kmeta;name=meta;branch=yocto-4.4;destsuffix=${KMETA}"