aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorJoshua Lock <joshua.g.lock@intel.com>2016-03-11 12:13:32 +0000
committerRichard Purdie <richard.purdie@linuxfoundation.org>2016-03-12 22:11:46 +0000
commit09eab6b992c9ef1885ccfd6740c95b66df7c2809 (patch)
tree174aeba60d5e093bdb4fb39f906dbe6e33c9cf70
parent8ea5cdc77633831a34aeb09ccd7592b3a5ecbd3d (diff)
downloadopenembedded-core-contrib-09eab6b992c9ef1885ccfd6740c95b66df7c2809.tar.gz
build-appliance: make the inclusion of downloaded sources optional
Including the entirety of DL_DIR in the generated build appliance image adds a significant amount of space and makes the build appliance image more awkward to distribute. Add a configuration option to make the inclusion of sources option and default to disabling this functionality. (From OE-Core rev: 7975325e3d8dee159752ae2304b0c00361bfd2a7) Signed-off-by: Joshua Lock <joshua.g.lock@intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
-rw-r--r--meta/recipes-core/images/build-appliance-image_14.0.0.bb5
1 files changed, 4 insertions, 1 deletions
diff --git a/meta/recipes-core/images/build-appliance-image_14.0.0.bb b/meta/recipes-core/images/build-appliance-image_14.0.0.bb
index 8f9ce1b662..61f69f42ec 100644
--- a/meta/recipes-core/images/build-appliance-image_14.0.0.bb
+++ b/meta/recipes-core/images/build-appliance-image_14.0.0.bb
@@ -26,6 +26,7 @@ SRC_URI = "git://git.yoctoproject.org/poky \
file://Yocto_Build_Appliance.vmx \
file://Yocto_Build_Appliance.vmxf \
"
+BA_INCLUDE_SOURCES ??= "0"
IMAGE_CMD_ext4_append () {
# We don't need to reserve much space for root, 0.5% is more than enough
@@ -42,7 +43,9 @@ fakeroot do_populate_poky_src () {
mkdir -p ${IMAGE_ROOTFS}/home/builder/poky/build/conf
mkdir -p ${IMAGE_ROOTFS}/home/builder/poky/build/downloads
- cp -RpL ${DL_DIR}/* ${IMAGE_ROOTFS}/home/builder/poky/build/downloads/
+ if [ ${BA_INCLUDE_SOURCES} != 0 ]; then
+ cp -RpL ${DL_DIR}/* ${IMAGE_ROOTFS}/home/builder/poky/build/downloads/
+ fi
# Remove the git2_* tarballs -- this is ok since we still have the git2/.
rm -rf ${IMAGE_ROOTFS}/home/builder/poky/build/downloads/git2_*