aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRichard Purdie <richard.purdie@linuxfoundation.org>2017-02-03 12:06:06 +0000
committerRichard Purdie <richard.purdie@linuxfoundation.org>2017-02-09 10:52:03 +0000
commit5e68071c6f802f46a965f08ede8d1aa6770d97fe (patch)
tree6d8b4bdf5502732d6ef7dc23809b2e46957be2d7
parent7d08a1340f4751ced35a9cf66d022f1cf0a105de (diff)
downloadopenembedded-core-contrib-5e68071c6f802f46a965f08ede8d1aa6770d97fe.tar.gz
python3-native: Remove tests to save copying uneeded files around
Removing these nearly halves the python3-native disk footprint meaning more optimal sysroot operations. We don't need these tests for anything. (From OE-Core rev: 5c8dda390cacef69bc7996eb26099d55e2b8427b) Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
-rw-r--r--meta/recipes-devtools/python/python3-native_3.5.2.bb3
1 files changed, 3 insertions, 0 deletions
diff --git a/meta/recipes-devtools/python/python3-native_3.5.2.bb b/meta/recipes-devtools/python/python3-native_3.5.2.bb
index 7ac3942831..bf4e6860fa 100644
--- a/meta/recipes-devtools/python/python3-native_3.5.2.bb
+++ b/meta/recipes-devtools/python/python3-native_3.5.2.bb
@@ -98,4 +98,7 @@ do_install() {
for PYTHSCRIPT in `grep -rIl ${bindir}/${PN}/python ${D}${bindir}/${PN}`; do
sed -i -e '1s|^#!.*|#!/usr/bin/env python3|' $PYTHSCRIPT
done
+
+ # Tests are large and we don't need them in the native sysroot
+ rm ${D}${libdir}/python${PYTHON_MAJMIN}/test -rf
}