aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRobert Yang <liezhi.yang@windriver.com>2016-04-11 23:36:43 -0700
committerRichard Purdie <richard.purdie@linuxfoundation.org>2016-04-13 10:12:53 +0100
commit6d85874180dc51005ee74a15465e907fddd9fac2 (patch)
tree9a8e885b265e8864a92bd6bda4c28438c2a80664
parent440d949b63a9d454d575a2d3083cb4bef4f75c78 (diff)
downloadopenembedded-core-contrib-6d85874180dc51005ee74a15465e907fddd9fac2.tar.gz
linux-yocto-tiny: fix KBRANCH
Fixed: WARNING: linux-yocto-tiny-4.4.3+gitAUTOINC+770996a263_73481a3abd-r0 do_patch: After meta data application, the kernel tree branch is standard/tiny/common-pc. The WARNING: linux-yocto-tiny-4.4.3+gitAUTOINC+770996a263_73481a3abd-r0 do_patch: SRC_URI specified branch standard/tiny/base. The branch will be forced to standard/tiny/base, WARNING: linux-yocto-tiny-4.4.3+gitAUTOINC+770996a263_73481a3abd-r0 do_patch: but this means the board meta data (.scc files) do not match the SRC_URI specification. WARNING: linux-yocto-tiny-4.4.3+gitAUTOINC+770996a263_73481a3abd-r0 do_patch: The meta data and branch standard/tiny/base should be inspected to ensure the proper WARNING: linux-yocto-tiny-4.4.3+gitAUTOINC+770996a263_73481a3abd-r0 do_patch: kernel is being built. Use standard/tiny/common-pc which is pointed by the .scc to fix problem. Btw, standard/tiny/base and standard/tiny/common-pc points to the same commit id. (From OE-Core rev: 04556b33d5bf232ed4de14725cf94627f434131e) Signed-off-by: Robert Yang <liezhi.yang@windriver.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
-rw-r--r--meta/recipes-kernel/linux/linux-yocto-tiny_4.1.bb2
-rw-r--r--meta/recipes-kernel/linux/linux-yocto-tiny_4.4.bb2
2 files changed, 2 insertions, 2 deletions
diff --git a/meta/recipes-kernel/linux/linux-yocto-tiny_4.1.bb b/meta/recipes-kernel/linux/linux-yocto-tiny_4.1.bb
index 36f83b5265..22a8dbee4b 100644
--- a/meta/recipes-kernel/linux/linux-yocto-tiny_4.1.bb
+++ b/meta/recipes-kernel/linux/linux-yocto-tiny_4.1.bb
@@ -1,4 +1,4 @@
-KBRANCH ?= "standard/tiny/base"
+KBRANCH ?= "standard/tiny/common-pc"
LINUX_KERNEL_TYPE = "tiny"
KCONFIG_MODE = "--allnoconfig"
diff --git a/meta/recipes-kernel/linux/linux-yocto-tiny_4.4.bb b/meta/recipes-kernel/linux/linux-yocto-tiny_4.4.bb
index 04e6258dc8..9bae4faeb0 100644
--- a/meta/recipes-kernel/linux/linux-yocto-tiny_4.4.bb
+++ b/meta/recipes-kernel/linux/linux-yocto-tiny_4.4.bb
@@ -1,4 +1,4 @@
-KBRANCH ?= "standard/tiny/base"
+KBRANCH ?= "standard/tiny/common-pc"
LINUX_KERNEL_TYPE = "tiny"
KCONFIG_MODE = "--allnoconfig"