aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRichard Purdie <richard.purdie@linuxfoundation.org>2014-04-11 17:38:18 +0100
committerRichard Purdie <richard.purdie@linuxfoundation.org>2014-04-21 23:03:18 +0100
commit392de9d5685e17aed868eb5659032103748825f4 (patch)
treedf0ea22b9719dbddb374aeb185ec9760eccd74bb
parent982aa36251a4a855102575b8a590929787c645fd (diff)
downloadopenembedded-core-contrib-392de9d5685e17aed868eb5659032103748825f4.tar.gz
bitbake: doc: Rename user-manual -> bitbake-user-manual
This manual gets combined with other manuals and in that context, it helps a lot if its seen as the Bitbake User Manual. Renames are a pain but this is worthwhile so that other docs can correctly be combined with this one. This also clarifies things like google search results which is helpful. (Bitbake rev: 452a62ae0c2793e281d6769fd3e45500a74898d6) Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
-rw-r--r--bitbake/doc/Makefile14
-rw-r--r--bitbake/doc/README4
-rw-r--r--bitbake/doc/bitbake-user-manual/bitbake-user-manual-customization.xsl (renamed from bitbake/doc/user-manual/user-manual-customization.xsl)0
-rw-r--r--bitbake/doc/bitbake-user-manual/bitbake-user-manual-execution.xml (renamed from bitbake/doc/user-manual/user-manual-execution.xml)4
-rw-r--r--bitbake/doc/bitbake-user-manual/bitbake-user-manual-fetching.xml (renamed from bitbake/doc/user-manual/user-manual-fetching.xml)0
-rw-r--r--bitbake/doc/bitbake-user-manual/bitbake-user-manual-hello.xml (renamed from bitbake/doc/user-manual/user-manual-hello.xml)2
-rw-r--r--bitbake/doc/bitbake-user-manual/bitbake-user-manual-intro.xml (renamed from bitbake/doc/user-manual/user-manual-intro.xml)4
-rw-r--r--bitbake/doc/bitbake-user-manual/bitbake-user-manual-metadata.xml (renamed from bitbake/doc/user-manual/user-manual-metadata.xml)2
-rw-r--r--bitbake/doc/bitbake-user-manual/bitbake-user-manual-ref-variables.xml (renamed from bitbake/doc/user-manual/user-manual-ref-variables.xml)0
-rw-r--r--bitbake/doc/bitbake-user-manual/bitbake-user-manual-style.css (renamed from bitbake/doc/user-manual/user-manual-style.css)0
-rw-r--r--bitbake/doc/bitbake-user-manual/bitbake-user-manual.xml (renamed from bitbake/doc/user-manual/user-manual.xml)12
-rw-r--r--bitbake/doc/bitbake-user-manual/figures/bitbake-title.png (renamed from bitbake/doc/user-manual/figures/bitbake-title.png)bin5086 -> 5086 bytes
-rw-r--r--bitbake/doc/bitbake-user-manual/html.css (renamed from bitbake/doc/user-manual/html.css)0
-rw-r--r--bitbake/doc/template/titlepage.templates.xml4
14 files changed, 23 insertions, 23 deletions
diff --git a/bitbake/doc/Makefile b/bitbake/doc/Makefile
index 6b2af67326..8e98c57eb1 100644
--- a/bitbake/doc/Makefile
+++ b/bitbake/doc/Makefile
@@ -18,21 +18,21 @@
#
# Examples:
#
-# make DOC=user-manual
-# make pdf DOC=user-manual
+# make DOC=bitbake-user-manual
+# make pdf DOC=bitbake-user-manual
#
# The first example generates the HTML and PDF versions of the User Manual.
# The second example generates the HTML version only of the User Manual.
#
-ifeq ($(DOC),user-manual)
-XSLTOPTS = --stringparam html.stylesheet user-manual-style.css \
+ifeq ($(DOC),bitbake-user-manual)
+XSLTOPTS = --stringparam html.stylesheet bitbake-user-manual-style.css \
--stringparam chapter.autolabel 1 \
--stringparam section.autolabel 1 \
--stringparam section.label.includes.component.label 1 \
--xinclude
ALLPREQ = html pdf tarball
-TARFILES = user-manual-style.css user-manual.html user-manual.pdf figures/bitbake-title.png
+TARFILES = bitbake-user-manual-style.css bitbake-user-manual.html bitbake-user-manual.pdf figures/bitbake-title.png
MANUALS = $(DOC)/$(DOC).html $(DOC)/$(DOC).pdf
FIGURES = figures
STYLESHEET = $(DOC)/*.css
@@ -48,7 +48,7 @@ XSL_XHTML_URI = $(XSL_BASE_URI)/xhtml/docbook.xsl
all: $(ALLPREQ)
pdf:
-ifeq ($(DOC),user-manual)
+ifeq ($(DOC),bitbake-user-manual)
@echo " "
@echo "********** Building."$(DOC)
@echo " "
@@ -56,7 +56,7 @@ ifeq ($(DOC),user-manual)
endif
html:
-ifeq ($(DOC),user-manual)
+ifeq ($(DOC),bitbake-user-manual)
# See http://www.sagehill.net/docbookxsl/HtmlOutput.html
@echo " "
@echo "******** Building "$(DOC)
diff --git a/bitbake/doc/README b/bitbake/doc/README
index 90aafea9cb..303cf8eec7 100644
--- a/bitbake/doc/README
+++ b/bitbake/doc/README
@@ -8,7 +8,7 @@ Manual Organization
Folders exist for individual manuals as follows:
-* user-manual - The BitBake User Manual
+* bitbake-user-manual - The BitBake User Manual
Each folder is self-contained regarding content and figures.
@@ -28,7 +28,7 @@ For example, the following command run from the documentation directory
creates an HTML and a PDF version of the BitBake User Manual.
The DOC variable specifies the manual you are making:
- $ make DOC=user-manual
+ $ make DOC=bitbake-user-manual
template
========
diff --git a/bitbake/doc/user-manual/user-manual-customization.xsl b/bitbake/doc/bitbake-user-manual/bitbake-user-manual-customization.xsl
index a8ec28ae20..a8ec28ae20 100644
--- a/bitbake/doc/user-manual/user-manual-customization.xsl
+++ b/bitbake/doc/bitbake-user-manual/bitbake-user-manual-customization.xsl
diff --git a/bitbake/doc/user-manual/user-manual-execution.xml b/bitbake/doc/bitbake-user-manual/bitbake-user-manual-execution.xml
index 1cb7fc63ce..8514f23f25 100644
--- a/bitbake/doc/user-manual/user-manual-execution.xml
+++ b/bitbake/doc/bitbake-user-manual/bitbake-user-manual-execution.xml
@@ -1,7 +1,7 @@
<!DOCTYPE chapter PUBLIC "-//OASIS//DTD DocBook XML V4.2//EN"
"http://www.oasis-open.org/docbook/xml/4.2/docbookx.dtd">
-<chapter id="user-manual-execution">
+<chapter id="bitbake-user-manual-execution">
<title>Execution</title>
<para>
@@ -24,7 +24,7 @@
</literallayout>
For information on the BitBake command and its options,
see
- "<link linkend='user-manual-command'>The BitBake Command</link>"
+ "<link linkend='bitbake-user-manual-command'>The BitBake Command</link>"
section.
</para>
diff --git a/bitbake/doc/user-manual/user-manual-fetching.xml b/bitbake/doc/bitbake-user-manual/bitbake-user-manual-fetching.xml
index 5aa53defc4..5aa53defc4 100644
--- a/bitbake/doc/user-manual/user-manual-fetching.xml
+++ b/bitbake/doc/bitbake-user-manual/bitbake-user-manual-fetching.xml
diff --git a/bitbake/doc/user-manual/user-manual-hello.xml b/bitbake/doc/bitbake-user-manual/bitbake-user-manual-hello.xml
index 5a616e07b3..3215e49a28 100644
--- a/bitbake/doc/user-manual/user-manual-hello.xml
+++ b/bitbake/doc/bitbake-user-manual/bitbake-user-manual-hello.xml
@@ -130,7 +130,7 @@
While every attempt is made to explain what is happening,
not everything can be covered.
You can find further information in the
- "<link linkend='user-manual-metadata'>Syntax and Operators</link>"
+ "<link linkend='bitbake-user-manual-metadata'>Syntax and Operators</link>"
chapter.
</para>
diff --git a/bitbake/doc/user-manual/user-manual-intro.xml b/bitbake/doc/bitbake-user-manual/bitbake-user-manual-intro.xml
index cd05fc5d07..ae267b42c8 100644
--- a/bitbake/doc/user-manual/user-manual-intro.xml
+++ b/bitbake/doc/bitbake-user-manual/bitbake-user-manual-intro.xml
@@ -1,7 +1,7 @@
<!DOCTYPE chapter PUBLIC "-//OASIS//DTD DocBook XML V4.2//EN"
"http://www.oasis-open.org/docbook/xml/4.2/docbookx.dtd">
-<chapter id="user-manual-intro">
+<chapter id="bitbake-user-manual-intro">
<title>Overview</title>
<para>
@@ -417,7 +417,7 @@
</para>
</section>
- <section id="user-manual-command">
+ <section id="bitbake-user-manual-command">
<title>The BitBake Command</title>
<para>
diff --git a/bitbake/doc/user-manual/user-manual-metadata.xml b/bitbake/doc/bitbake-user-manual/bitbake-user-manual-metadata.xml
index a57fe0c814..41ae3b8c0a 100644
--- a/bitbake/doc/user-manual/user-manual-metadata.xml
+++ b/bitbake/doc/bitbake-user-manual/bitbake-user-manual-metadata.xml
@@ -1,7 +1,7 @@
<!DOCTYPE chapter PUBLIC "-//OASIS//DTD DocBook XML V4.2//EN"
"http://www.oasis-open.org/docbook/xml/4.2/docbookx.dtd">
-<chapter id="user-manual-metadata">
+<chapter id="bitbake-user-manual-metadata">
<title>Syntax and Operators</title>
<para>
diff --git a/bitbake/doc/user-manual/user-manual-ref-variables.xml b/bitbake/doc/bitbake-user-manual/bitbake-user-manual-ref-variables.xml
index 6a5af89ffa..6a5af89ffa 100644
--- a/bitbake/doc/user-manual/user-manual-ref-variables.xml
+++ b/bitbake/doc/bitbake-user-manual/bitbake-user-manual-ref-variables.xml
diff --git a/bitbake/doc/user-manual/user-manual-style.css b/bitbake/doc/bitbake-user-manual/bitbake-user-manual-style.css
index f7e95f76bf..f7e95f76bf 100644
--- a/bitbake/doc/user-manual/user-manual-style.css
+++ b/bitbake/doc/bitbake-user-manual/bitbake-user-manual-style.css
diff --git a/bitbake/doc/user-manual/user-manual.xml b/bitbake/doc/bitbake-user-manual/bitbake-user-manual.xml
index 9f94886c7f..e927c4d9e3 100644
--- a/bitbake/doc/user-manual/user-manual.xml
+++ b/bitbake/doc/bitbake-user-manual/bitbake-user-manual.xml
@@ -73,16 +73,16 @@
</legalnotice>
</bookinfo>
- <xi:include href="user-manual-intro.xml"/>
+ <xi:include href="bitbake-user-manual-intro.xml"/>
- <xi:include href="user-manual-execution.xml"/>
+ <xi:include href="bitbake-user-manual-execution.xml"/>
- <xi:include href="user-manual-metadata.xml"/>
+ <xi:include href="bitbake-user-manual-metadata.xml"/>
- <xi:include href="user-manual-fetching.xml"/>
+ <xi:include href="bitbake-user-manual-fetching.xml"/>
- <xi:include href="user-manual-ref-variables.xml"/>
+ <xi:include href="bitbake-user-manual-ref-variables.xml"/>
- <xi:include href="user-manual-hello.xml"/>
+ <xi:include href="bitbake-user-manual-hello.xml"/>
</book>
diff --git a/bitbake/doc/user-manual/figures/bitbake-title.png b/bitbake/doc/bitbake-user-manual/figures/bitbake-title.png
index cb290154da..cb290154da 100644
--- a/bitbake/doc/user-manual/figures/bitbake-title.png
+++ b/bitbake/doc/bitbake-user-manual/figures/bitbake-title.png
Binary files differ
diff --git a/bitbake/doc/user-manual/html.css b/bitbake/doc/bitbake-user-manual/html.css
index 6eedfd3189..6eedfd3189 100644
--- a/bitbake/doc/user-manual/html.css
+++ b/bitbake/doc/bitbake-user-manual/html.css
diff --git a/bitbake/doc/template/titlepage.templates.xml b/bitbake/doc/template/titlepage.templates.xml
index 6906604db6..38ec11a4c3 100644
--- a/bitbake/doc/template/titlepage.templates.xml
+++ b/bitbake/doc/template/titlepage.templates.xml
@@ -144,7 +144,7 @@
# If you leave this block of code in then the text title in the
# <title>BitBake User Manual</title> statement of the
-# user-manual.xml file is rendered on the title page below the
+# bitbake-user-manual.xml file is rendered on the title page below the
# image. Commenting it out gets it out of there yet allows it
# to be retained in the tab text for the HTML version of the
# manual.
@@ -176,7 +176,7 @@
<!--
# If you leave this block of code in then the text title in the
# <title>BitBake User Manual</title> statement of the
-# user-manual.xml file is rendered on the title page below the
+# bitbake-user-manual.xml file is rendered on the title page below the
# image. Commenting it out gets it out of there yet allows it
# to be retained in the tab text for the HTML version of the
# manual.