aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorAníbal Limón <anibal.limon@linux.intel.com>2016-12-01 10:34:25 -0600
committerRichard Purdie <richard.purdie@linuxfoundation.org>2017-03-01 23:27:10 +0000
commitef010c1a1d823870aba80152fc13c32c62e95146 (patch)
treea7ce0de895c6e09cd900f20fb6920eb64aae0b00
parent2cdaa0c493b61b73cbc3e53dc0b6ea6b510f2dad (diff)
downloadopenembedded-core-contrib-ef010c1a1d823870aba80152fc13c32c62e95146.tar.gz
perl-native: Remove usage of -fstack-protector=strong
Some distributions (like opensuse421) supported by the project comes with older gcc releases, -fstack-protector=strong is supported by GCC>=4.9. This causes a build failure when install perl-native from a sstate that comes from a machine supporting -fstack-protector=strong [1]. So disable usage of this flag in perl-native builds, this patch could be removed when all supported distros comes with GCC>=4.9. [YOCTO #10338] [1] http://errors.yoctoproject.org/Errors/Details/109589/ (From OE-Core rev: 37fd073526811dee6edcfbb78a1864dd37991f4d) Signed-off-by: Aníbal Limón <anibal.limon@linux.intel.com> Signed-off-by: Ross Burton <ross.burton@intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
-rw-r--r--meta/recipes-devtools/perl/perl-native_5.24.1.bb1
-rw-r--r--meta/recipes-devtools/perl/perl/0001-Configure-Remove-fstack-protector-strong-for-native-.patch103
2 files changed, 104 insertions, 0 deletions
diff --git a/meta/recipes-devtools/perl/perl-native_5.24.1.bb b/meta/recipes-devtools/perl/perl-native_5.24.1.bb
index d111bcdd42..896a379db6 100644
--- a/meta/recipes-devtools/perl/perl-native_5.24.1.bb
+++ b/meta/recipes-devtools/perl/perl-native_5.24.1.bb
@@ -11,6 +11,7 @@ SRC_URI += "\
file://debian/errno_ver.diff \
file://dynaloaderhack.patch \
file://perl-PathTools-don-t-filter-out-blib-from-INC.patch \
+ file://0001-Configure-Remove-fstack-protector-strong-for-native-.patch \
"
SRC_URI[md5sum] = "af6a84c7c3e2b8b269c105a5db2f6d53"
diff --git a/meta/recipes-devtools/perl/perl/0001-Configure-Remove-fstack-protector-strong-for-native-.patch b/meta/recipes-devtools/perl/perl/0001-Configure-Remove-fstack-protector-strong-for-native-.patch
new file mode 100644
index 0000000000..7391ac5837
--- /dev/null
+++ b/meta/recipes-devtools/perl/perl/0001-Configure-Remove-fstack-protector-strong-for-native-.patch
@@ -0,0 +1,103 @@
+Some distributions (like opensuse421) supported by the project
+comes with older gcc releases, -fstack-protector=strong is supported
+by GCC>=4.9.
+
+This causes a build failure when install perl-native from a sstate that
+comes from a machine supporting -fstack-protector=strong [1].
+
+So disable usage of this flag in perl-native builds, this patch could
+be removed when all supported distros comes with GCC>=4.9.
+
+[YOCTO #10338]
+
+Upstream-status: Inappropriate [configuration]
+
+[1] http://errors.yoctoproject.org/Errors/Details/109589/
+
+Signed-off-by: Aníbal Limón <anibal.limon@linux.intel.com>
+---
+ Configure | 54 ------------------------------------------------------
+ 1 file changed, 54 deletions(-)
+
+diff --git a/Configure b/Configure
+index efbdcfd..d5bd98c 100755
+--- a/Configure
++++ b/Configure
+@@ -5468,30 +5468,6 @@ default|recommended)
+ eval $checkccflag
+ ;;
+ esac
+-
+- # on x86_64 (at least) we require an extra library (libssp) in the
+- # link command line. This library is not named, so I infer that it is
+- # an implementation detail that may change. Hence the safest approach
+- # is to add the flag to the flags passed to the compiler at link time,
+- # as that way the compiler can do the right implementation dependant
+- # thing. (NWC)
+- case "$osname" in
+- amigaos) ;; # -fstack-protector builds but doesn't work
+- *) case "$gccversion" in
+- ?*) set stack-protector-strong -fstack-protector-strong
+- eval $checkccflag
+- case "$dflt" in
+- *-fstack-protector-strong*) ;; # It got added.
+- *) # Try the plain/older -fstack-protector.
+- set stack-protector -fstack-protector
+- eval $checkccflag
+- ;;
+- esac
+- ;;
+- esac
+- ;;
+- esac
+- ;;
+ esac
+
+ case "$mips_type" in
+@@ -5634,21 +5610,6 @@ case "$ldflags" in
+ ;;
+ *) dflt="$ldflags";;
+ esac
+-# See note above about -fstack-protector
+-case "$ccflags" in
+-*-fstack-protector-strong*)
+- case "$dflt" in
+- *-fstack-protector-strong*) ;; # Don't add it again
+- *) dflt="$dflt -fstack-protector-strong" ;;
+- esac
+- ;;
+-*-fstack-protector*)
+- case "$dflt" in
+- *-fstack-protector*) ;; # Don't add it again
+- *) dflt="$dflt -fstack-protector" ;;
+- esac
+- ;;
+-esac
+
+ : Try to guess additional flags to pick up local libraries.
+ for thislibdir in $libpth; do
+@@ -8571,21 +8532,6 @@ EOM
+ ''|' ') dflt='none' ;;
+ esac
+
+- case "$ldflags" in
+- *-fstack-protector-strong*)
+- case "$dflt" in
+- *-fstack-protector-strong*) ;; # Don't add it again
+- *) dflt="$dflt -fstack-protector-strong" ;;
+- esac
+- ;;
+- *-fstack-protector*)
+- case "$dflt" in
+- *-fstack-protector*) ;; # Don't add it again
+- *) dflt="$dflt -fstack-protector" ;;
+- esac
+- ;;
+- esac
+-
+ rp="Any special flags to pass to $ld to create a dynamically loaded library?"
+ . ./myread
+ case "$ans" in
+--
+2.1.4
+