aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorBeth Flanagan <elizabeth.flanagan@intel.com>2011-06-02 10:18:35 -0700
committerRichard Purdie <richard.purdie@linuxfoundation.org>2011-06-13 22:38:03 +0100
commit37eedd0ae3593f759a5e9e70e9dc1191171e09d0 (patch)
treeca2ae81c1163b3bdd7763d2e0dfcc5df282e5b72
parentbaf6bf4a5de176a5ad0fbaf436134c767eeed9ac (diff)
downloadopenembedded-core-contrib-37eedd0ae3593f759a5e9e70e9dc1191171e09d0.tar.gz
documentation: [YOCTO #1025] build system for docs
These changes fix the following issues: 1. Multiple Makefiles. There really is no need for this. 2. Unable to maintain more than one version of the docs on the webserver. This is a quick fix to enable the above. In order to build the documentation, at the top level, issue a: make all DOC=<doc directory name> make all DOC=kernel-manual Also, some changes need to occur on the webserver to fully incorporate these fixes. http://www.yoctoproject.org/documentation/ The docs are now published to: http://www.yoctoproject.org/docs/<Release MM.mm>/<doc name> The main page should be changed to point not only to the current doc release, but also to the prior releases. This will enable us to maintain prior release documentation without stomping over it when we publish new docs. Also, we'll need to repoint the yocto-quick-start link to yocto-project-qs. Or rename documentation/yocto-project-qs/* to support the website naming. (From yocto-docs rev: 2651790d80fd32cd4619eeb5375f6ee28e7e7fda) Signed-off-by: Beth Flanagan <elizabeth.flanagan@intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
-rw-r--r--documentation/Makefile84
-rw-r--r--documentation/adt-manual/Makefile44
-rw-r--r--documentation/bsp-guide/Makefile37
-rw-r--r--documentation/kernel-manual/Makefile38
-rw-r--r--documentation/kernel-manual/kernel-manual-customization.xsl (renamed from documentation/kernel-manual/yocto-project-kernel-manual-customization.xsl)0
-rw-r--r--documentation/poky-ref-manual/Makefile38
-rw-r--r--documentation/yocto-project-qs/Makefile34
7 files changed, 84 insertions, 191 deletions
diff --git a/documentation/Makefile b/documentation/Makefile
new file mode 100644
index 0000000000..a22abb23c2
--- /dev/null
+++ b/documentation/Makefile
@@ -0,0 +1,84 @@
+DISTROVERSION=1.1
+ifeq ($(DOC),bsp-guide)
+XSLTOPTS = --stringparam html.stylesheet style.css \
+ --stringparam chapter.autolabel 1 \
+ --stringparam section.autolabel 1 \
+ --stringparam section.label.includes.component.label 1 \
+ --xinclude
+ALLPREQ = html pdf tarball
+TARFILES = style.css bsp-guide.html bsp-guide.pdf figures/bsp-title.png
+endif
+
+ifeq ($(DOC),yocto-project-qs)
+XSLTOPTS = --stringparam html.stylesheet style.css \
+ --xinclude
+ALLPREQ = html tarball
+TARFILES = yocto-project-qs.html style.css figures/yocto-environment.png figures/building-an-image.png figures/using-a-pre-built-image.png figures/yocto-project-transp.png
+endif
+
+ifeq ($(DOC),poky-ref-manual)
+XSLTOPTS = --stringparam html.stylesheet style.css \
+ --stringparam chapter.autolabel 1 \
+ --stringparam appendix.autolabel A \
+ --stringparam section.autolabel 1 \
+ --stringparam section.label.includes.component.label 1 \
+ --xinclude
+ALLPREQ = html pdf tarball
+TARFILES = poky-ref-manual.html style.css figures/poky-title.png figures/ss-sato.png
+endif
+
+
+ifeq ($(DOC),adt-manual)
+XSLTOPTS = --stringparam html.stylesheet style.css \
+ --stringparam chapter.autolabel 1 \
+ --stringparam appendix.autolabel A \
+ --stringparam section.autolabel 1 \
+ --stringparam section.label.includes.component.label 1 \
+ --xinclude
+ALLPREQ = html pdf tarball
+TARFILES = adt-manual.html adt-manual.pdf style.css figures/adt-title.png
+endif
+
+ifeq ($(DOC),kernel-manual)
+XSLTOPTS = --stringparam html.stylesheet style.css \
+ --stringparam chapter.autolabel 1 \
+ --stringparam appendix.autolabel A \
+ --stringparam section.autolabel 1 \
+ --stringparam section.label.includes.component.label 1 \
+ --xinclude
+ALLPREQ = html pdf tarball
+TARFILES = kernel-manual.html kernel-manual.pdf style.css figures/kernel-title.png figures/kernel-architecture-overview.png
+endif
+
+
+##
+# These URI should be rewritten by your distribution's xml catalog to
+# match your localy installed XSL stylesheets.
+XSL_BASE_URI = http://docbook.sourceforge.net/release/xsl/current
+XSL_XHTML_URI = $(XSL_BASE_URI)/xhtml/docbook.xsl
+
+all: $(ALLPREQ)
+
+pdf:
+ cd $(DOC); ../tools/poky-docbook-to-pdf $(DOC).xml ../template; cd ..
+
+html:
+# See http://www.sagehill.net/docbookxsl/HtmlOutput.html
+ cd $(DOC); xsltproc $(XSLTOPTS) -o $(DOC).html $(DOC)-customization.xsl $(DOC).xml; cd ..
+
+tarball: html
+ cd $(DOC); tar -cvzf $(DOC).tgz $(TARFILES); cd ..
+
+validate:
+ cd $(DOC); xmllint --postvalid --xinclude --noout $(DOC).xml; cd ..
+
+MANUALS = $(DOC)/$(DOC).html $(DOC)/$(DOC).pdf
+FIGURES = $(DOC)/figures/*.png
+STYLESHEET = *.css
+
+publish:
+ scp -r $(MANUALS) $(STYLESHEET) www.yoctoproject.org:/srv/www/www.yoctoproject.org-docs/$(DISTROVERSION)/$(DOC)
+ scp -r $(FIGURES) www.yoctoproject.org:/srv/www/www.yoctoproject.org-docs/$(DISTROVERSION)/$(DOC)/figures
+
+clean:
+ rm -f $(MANUALS)
diff --git a/documentation/adt-manual/Makefile b/documentation/adt-manual/Makefile
deleted file mode 100644
index fe16a57f35..0000000000
--- a/documentation/adt-manual/Makefile
+++ /dev/null
@@ -1,44 +0,0 @@
-XSLTOPTS = --stringparam html.stylesheet style.css \
- --stringparam chapter.autolabel 1 \
- --stringparam appendix.autolabel A \
- --stringparam section.autolabel 1 \
- --stringparam section.label.includes.component.label 1 \
- --xinclude
-
-##
-# These URI should be rewritten by your distribution's xml catalog to
-# match your localy installed XSL stylesheets.
-XSL_BASE_URI = http://docbook.sourceforge.net/release/xsl/current
-XSL_XHTML_URI = $(XSL_BASE_URI)/xhtml/docbook.xsl
-
-all: html pdf tarball
-
-pdf:
- ../tools/poky-docbook-to-pdf adt-manual.xml ../template
-
-##
-# These URI should be rewritten by your distribution's xml catalog to
-# match your localy installed XSL stylesheets.
-
-html:
-# See http://www.sagehill.net/docbookxsl/HtmlOutput.html
-
-# xsltproc $(XSLTOPTS) -o adt-manual.html $(XSL_XHTML_URI) adt-manual.xml
- xsltproc $(XSLTOPTS) -o adt-manual.html adt-manual-customization.xsl adt-manual.xml
-
-tarball: html
- tar -cvzf adt-manual.tgz adt-manual.html adt-manual.pdf style.css figures/adt-title.png
-
-validate:
- xmllint --postvalid --xinclude --noout adt-manual.xml
-
-MANUALS = adt-manual.html adt-manual.pdf
-FIGURES = figures/*.png
-STYLESHEET = *.css
-
-publish:
- scp -r $(MANUALS) $(STYLESHEET) www.yoctoproject.org:/srv/www/www.yoctoproject.org-docs/adt-manual
- scp -r $(FIGURES) www.yoctoproject.org:/srv/www/www.yoctoproject.org-docs/adt-manual/figures
-
-clean:
- rm -f $(MANUALS)
diff --git a/documentation/bsp-guide/Makefile b/documentation/bsp-guide/Makefile
deleted file mode 100644
index 36ca48a62a..0000000000
--- a/documentation/bsp-guide/Makefile
+++ /dev/null
@@ -1,37 +0,0 @@
-XSLTOPTS = --stringparam html.stylesheet style.css \
- --stringparam chapter.autolabel 1 \
- --stringparam section.autolabel 1 \
- --stringparam section.label.includes.component.label 1 \
- --xinclude
-
-##
-# These URI should be rewritten by your distribution's xml catalog to
-# match your localy installed XSL stylesheets.
-XSL_BASE_URI = http://docbook.sourceforge.net/release/xsl/current
-XSL_XHTML_URI = $(XSL_BASE_URI)/xhtml/docbook.xsl
-
-all: html pdf tarball
-
-pdf:
- ../tools/poky-docbook-to-pdf bsp-guide.xml ../template
-
-html:
-# See http://www.sagehill.net/docbookxsl/HtmlOutput.html
- xsltproc $(XSLTOPTS) -o bsp-guide.html bsp-guide-customization.xsl bsp-guide.xml
-
-tarball: html
- tar -cvzf bsp-guide.tgz style.css bsp-guide.html bsp-guide.pdf figures/bsp-title.png
-
-validate:
- xmllint --postvalid --xinclude --noout bsp-guide.xml
-
-MANUALS = bsp-guide.html bsp-guide.pdf
-FIGURES = figures/*.png
-STYLESHEET = *.css
-
-publish:
- scp -r $(MANUALS) $(STYLESHEET) www.yoctoproject.org:/srv/www/www.yoctoproject.org-docs/bsp-guide
- scp -r $(FIGURES) www.yoctoproject.org:/srv/www/www.yoctoproject.org-docs/bsp-guide/figures
-
-clean:
- rm -f $(OUTPUTS)
diff --git a/documentation/kernel-manual/Makefile b/documentation/kernel-manual/Makefile
deleted file mode 100644
index b691da8111..0000000000
--- a/documentation/kernel-manual/Makefile
+++ /dev/null
@@ -1,38 +0,0 @@
-XSLTOPTS = --stringparam html.stylesheet style.css \
- --stringparam chapter.autolabel 1 \
- --stringparam appendix.autolabel A \
- --stringparam section.autolabel 1 \
- --stringparam section.label.includes.component.label 1 \
- --xinclude
-
-##
-# These URI should be rewritten by your distribution's xml catalog to
-# match your localy installed XSL stylesheets.
-XSL_BASE_URI = http://docbook.sourceforge.net/release/xsl/current
-XSL_XHTML_URI = $(XSL_BASE_URI)/xhtml/docbook.xsl
-
-all: html pdf tarball
-
-pdf:
- ../tools/poky-docbook-to-pdf kernel-manual.xml ../template
-
-html:
-# See http://www.sagehill.net/docbookxsl/HtmlOutput.html
- xsltproc $(XSLTOPTS) -o kernel-manual.html yocto-project-kernel-manual-customization.xsl kernel-manual.xml
-
-tarball: html
- tar -cvzf kernel-manual.tgz kernel-manual.html kernel-manual.pdf style.css figures/kernel-title.png figures/kernel-architecture-overview.png
-
-validate:
- xmllint --postvalid --xinclude --noout kernel-manual.xml
-
-MANUALS = kernel-manual.html kernel-manual.pdf
-FIGURES = figures/*.png
-STYLESHEET = *.css
-
-publish:
- scp -r $(MANUALS) $(STYLESHEET) www.yoctoproject.org:/srv/www/www.yoctoproject.org-docs/kernel-manual
- scp -r $(FIGURES) www.yoctoproject.org:/srv/www/www.yoctoproject.org-docs/kernel-manual/figures
-
-clean:
- rm -f $(OUTPUTS)
diff --git a/documentation/kernel-manual/yocto-project-kernel-manual-customization.xsl b/documentation/kernel-manual/kernel-manual-customization.xsl
index 8eb69050ba..8eb69050ba 100644
--- a/documentation/kernel-manual/yocto-project-kernel-manual-customization.xsl
+++ b/documentation/kernel-manual/kernel-manual-customization.xsl
diff --git a/documentation/poky-ref-manual/Makefile b/documentation/poky-ref-manual/Makefile
deleted file mode 100644
index bb70a05d87..0000000000
--- a/documentation/poky-ref-manual/Makefile
+++ /dev/null
@@ -1,38 +0,0 @@
-XSLTOPTS = --stringparam html.stylesheet style.css \
- --stringparam chapter.autolabel 1 \
- --stringparam appendix.autolabel A \
- --stringparam section.autolabel 1 \
- --stringparam section.label.includes.component.label 1 \
- --xinclude
-
-##
-# These URI should be rewritten by your distribution's xml catalog to
-# match your localy installed XSL stylesheets.
-XSL_BASE_URI = http://docbook.sourceforge.net/release/xsl/current
-XSL_XHTML_URI = $(XSL_BASE_URI)/xhtml/docbook.xsl
-
-all: html pdf tarball
-
-pdf:
- ../tools/poky-docbook-to-pdf poky-ref-manual.xml ../template
-
-html:
-# See http://www.sagehill.net/docbookxsl/HtmlOutput.html
- xsltproc $(XSLTOPTS) -o poky-ref-manual.html poky-ref-manual-customization.xsl poky-ref-manual.xml
-
-tarball: html
- tar -cvzf poky-ref-manual.tgz poky-ref-manual.html style.css figures/poky-title.png figures/ss-sato.png
-
-validate:
- xmllint --postvalid --xinclude --noout poky-ref-manual.xml
-
-MANUALS = poky-ref-manual.html poky-ref-manual.pdf
-FIGURES = figures/*.png
-STYLESHEET = *.css
-
-publish:
- scp -r $(MANUALS) $(STYLESHEET) www.yoctoproject.org:/srv/www/www.yoctoproject.org-docs/poky-ref-manual
- scp -r $(FIGURES) www.yoctoproject.org:/srv/www/www.yoctoproject.org-docs/poky-ref-manual/figures
-
-clean:
- rm -f $(OUTPUTS)
diff --git a/documentation/yocto-project-qs/Makefile b/documentation/yocto-project-qs/Makefile
deleted file mode 100644
index 2c7bdf86a0..0000000000
--- a/documentation/yocto-project-qs/Makefile
+++ /dev/null
@@ -1,34 +0,0 @@
-XSLTOPTS = --stringparam html.stylesheet style.css \
- --xinclude
-
-XSL_BASE_URI = http://docbook.sourceforge.net/release/xsl/current
-XSL_XHTML_URI = $(XSL_BASE_URI)/xhtml/docbook.xsl
-
-all: html tarball
-
-##
-# These URI should be rewritten by your distribution's xml catalog to
-# match your localy installed XSL stylesheets.
-
-html:
-# See http://www.sagehill.net/docbookxsl/HtmlOutput.html
-
-# xsltproc $(XSLTOPTS) -o yocto-project-qs.html $(XSL_XHTML_URI) yocto-project-qs.xml
- xsltproc $(XSLTOPTS) -o yocto-project-qs.html yocto-project-qs-customization.xsl yocto-project-qs.xml
-
-tarball: html
- tar -cvzf yocto-project-qs.tgz yocto-project-qs.html style.css figures/yocto-environment.png figures/building-an-image.png figures/using-a-pre-built-image.png figures/yocto-project-transp.png
-
-validate:
- xmllint --postvalid --xinclude --noout yocto-project-qs.xml
-
-MANUALS = yocto-project-qs.html
-FIGURES = figures/*.png
-STYLESHEET = *.css
-
-publish:
- scp -r $(MANUALS) $(STYLESHEET) www.yoctoproject.org:/srv/www/www.yoctoproject.org-docs/yocto-quick-start
- scp -r $(FIGURES) www.yoctoproject.org:/srv/www/www.yoctoproject.org-docs/yocto-quick-start/figures
-
-clean:
- rm -f $(MANUALS)