aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorBruce Ashfield <bruce.ashfield@windriver.com>2016-11-16 09:24:35 -0500
committerRichard Purdie <richard.purdie@linuxfoundation.org>2016-11-30 15:48:05 +0000
commita08c78ddd49baecfcc572ff2b49982f3481c81e5 (patch)
tree44fee7d503d023ed3be84442a021acb99e9e8af7
parentb47ee25357f554c97fc3c8f79b53e088c602334f (diff)
downloadopenembedded-core-contrib-a08c78ddd49baecfcc572ff2b49982f3481c81e5.tar.gz
kern-tools: error checking and tree generation fixes
During processing of the kernel meta data the kern tools were not properly exiting on syntax errors or invalid commands. Noticing and debugging these issues wasn't trivial. To make this easier, we now trap the error and dump the offending meta-data for the user to see. There was also an issue with creating branches during tree generation, which is resolved by always switching to the active branch. The following are the commit logs of the changes themselves: [ commit b36f6f9a5695f2084b83823393e13ca42284bed9 Author: Paul Gortmaker <paul.gortmaker@windriver.com> Date: Sat Oct 22 17:23:25 2016 -0400 kgit-scc: dont mention meta-repo in help ; it doesnt exist Signed-off-by: Paul Gortmaker <paul.gortmaker@windriver.com> Signed-off-by: Bruce Ashfield <bruce.ashfield@windriver.com> commit 08463d684c1952e74c25344cddace4c3f24c739d Author: Bruce Ashfield <bruce.ashfield@windriver.com> Date: Mon Oct 31 14:30:12 2016 -0400 scc: exit on error If there is an error in the processing of the input files, scc should exit and inform the user. scc is executed on a combined/preprocessed file and as a result it doesn't have the granularity to see each input file individually. Rather than moving preprocessing into scc (from spp), we can trap the line number of the error and dump context around the line. This gives the user a pointer to the input file and the specific line that caused the problem. Signed-off-by: Bruce Ashfield <bruce.ashfield@windriver.com> commit bf99953e8ac14cee653e559f2d4a6022c847a182 Author: Bruce Ashfield <bruce.ashfield@windriver.com> Date: Fri Oct 28 21:23:27 2016 -0400 kgit-meta: always checkout branches on branch commands During a tree generation we must always make the branch active when we see any kind of branch command. This ensures that any subsequent patches are applied in the proper context. Previously, only branch creation was changing the active branch, and this mean that tree generation was not determinstic and relied on the order of processing to generate a correct tree. Signed-off-by: Bruce Ashfield <bruce.ashfield@windriver.com> ] (From OE-Core rev: 83d10e2acef936b1f38804988f10eafa48db36f9) Signed-off-by: Bruce Ashfield <bruce.ashfield@windriver.com> Signed-off-by: Ross Burton <ross.burton@intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
-rw-r--r--meta/recipes-kernel/kern-tools/kern-tools-native_git.bb2
1 files changed, 1 insertions, 1 deletions
diff --git a/meta/recipes-kernel/kern-tools/kern-tools-native_git.bb b/meta/recipes-kernel/kern-tools/kern-tools-native_git.bb
index d8041ddd38..88b1aee729 100644
--- a/meta/recipes-kernel/kern-tools/kern-tools-native_git.bb
+++ b/meta/recipes-kernel/kern-tools/kern-tools-native_git.bb
@@ -4,7 +4,7 @@ LIC_FILES_CHKSUM = "file://git/tools/kgit;beginline=5;endline=9;md5=a6c2fa8aef1b
DEPENDS = "git-native"
-SRCREV = "9a3995ee8daabf37e92e1b51b133cf8582d85809"
+SRCREV = "b36f6f9a5695f2084b83823393e13ca42284bed9"
PR = "r12"
PV = "0.2+git${SRCPV}"