summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorDaniel McGregor <daniel.mcgregor@vecima.com>2022-09-26 18:55:52 -0600
committerDaniel McGregor <daniel.mcgregor@vecima.com>2022-09-27 09:19:07 -0600
commit5a64b771d1787c629d79ecc0a4102db824c369ff (patch)
treec7e7ef8df6ad402aa8344fe7329e2c0bf37035dc
parent4a7b3ef0a69b7e08030519b712a6fe4dd199c571 (diff)
downloadopenembedded-core-contrib-5a64b771d1787c629d79ecc0a4102db824c369ff.tar.gz
coreutils: add openssl PACKAGECONFIG
coreutils-native will pick up openssl on the host if it's GPL compatible (version >= 3), which causes uninative failures with hosts that don't have openssl3. Add a PACKAGECONFIG entry for openssl so it can be enabled, but isn't by default. Signed-off-by: Daniel McGregor <daniel.mcgregor@vecima.com>
-rw-r--r--meta/recipes-core/coreutils/coreutils_9.1.bb1
1 files changed, 1 insertions, 0 deletions
diff --git a/meta/recipes-core/coreutils/coreutils_9.1.bb b/meta/recipes-core/coreutils/coreutils_9.1.bb
index 55663c7713..4807eefd04 100644
--- a/meta/recipes-core/coreutils/coreutils_9.1.bb
+++ b/meta/recipes-core/coreutils/coreutils_9.1.bb
@@ -46,6 +46,7 @@ PACKAGECONFIG[acl] = "--enable-acl,--disable-acl,acl,"
PACKAGECONFIG[xattr] = "--enable-xattr,--disable-xattr,attr,"
PACKAGECONFIG[single-binary] = "--enable-single-binary,--disable-single-binary,,"
PACKAGECONFIG[selinux] = "--with-selinux,--without-selinux,libselinux"
+PACKAGECONFIG[openssl] = "--with-openssl=yes,--with-openssl=no,openssl"
# [ df mktemp nice printenv base64 gets a special treatment and is not included in this
bindir_progs = "arch basename chcon cksum comm csplit cut dir dircolors dirname du \