aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorChen Qi <Qi.Chen@windriver.com>2014-12-30 17:11:57 +0800
committerRichard Purdie <richard.purdie@linuxfoundation.org>2015-01-29 10:37:52 +0000
commit5e7d6f40149be69a3e3b17b28ce3f687a93b40fa (patch)
treee956363e634a17381866d49d0734b8ec2d51deb0
parentb45e54137cfb013fd473507d5d1406f8807e0e63 (diff)
downloadopenembedded-core-contrib-5e7d6f40149be69a3e3b17b28ce3f687a93b40fa.tar.gz
libsm: remove dependency on e2fsprogs
This patch is to solve the following circular dependency problem. systemd -> dbus -> libsm -> e2fsprogs -> util-linux -> systemd libsm doesn't have any dependency on e2fsprogs. It might be some dependency on util-linux's libuuid, controlled by configure options. So e2fsprogs should be removed from the DEPENDS variable. Ideally, we should add a PACKAGECONFIG for 'libuuid' for libsm. However, if libsm depends on util-linux, we would have the circular dependency described above. That's why this patch explicitly set '--without-libuuid' in EXTRA_OECONF. libsm would still be working well because it would fall back to an internal algorithm to do the uuid stuff. Signed-off-by: Chen Qi <Qi.Chen@windriver.com>
-rw-r--r--meta/recipes-graphics/xorg-lib/libsm_1.2.2.bb7
1 files changed, 6 insertions, 1 deletions
diff --git a/meta/recipes-graphics/xorg-lib/libsm_1.2.2.bb b/meta/recipes-graphics/xorg-lib/libsm_1.2.2.bb
index 180acfae0b..1925136369 100644
--- a/meta/recipes-graphics/xorg-lib/libsm_1.2.2.bb
+++ b/meta/recipes-graphics/xorg-lib/libsm_1.2.2.bb
@@ -11,7 +11,12 @@ require xorg-lib-common.inc
LICENSE = "MIT-style"
LIC_FILES_CHKSUM = "file://COPYING;md5=c0fb37f44e02bdbde80546024400728d"
-DEPENDS += "libice xproto xtrans e2fsprogs"
+DEPENDS += "libice xproto xtrans"
+
+# libSM can work without libuuid, we explicitly disable it to break the following circular dependency
+# when DISTRO_FEATURES contains 'systemd' and 'x11'.
+# systemd -> dbus -> libsm -> util-linux -> systemd
+EXTRA_OECONF += "--without-libuuid"
PE = "1"