aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorWolfgang Denk <wd@denx.de>2014-11-05 20:29:51 +0100
committerRichard Purdie <richard.purdie@linuxfoundation.org>2014-12-31 10:17:25 +0000
commitdf4ace81f24e17d5fbf68ddf012b18d4bfc8c156 (patch)
tree23e566f93bfa172607e075ca3cca36a1700f7ee3
parent239dd6d2a15677fc21bdae5ce601390b71d4b14a (diff)
downloadopenembedded-core-contrib-df4ace81f24e17d5fbf68ddf012b18d4bfc8c156.tar.gz
perl: fix PERL5LIB settings
The PERL5LIB settings in the perl wrapper script did not include the "site_perl" or "vendor_perl" directories, which caused some errors. See https://bugzilla.yoctoproject.org/show_bug.cgi?id=6890 (From OE-Core rev: 477ca2da14abaf072d3645c4be916760a48b8938) Signed-off-by: Wolfgang Denk <wd@denx.de> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org> Signed-off-by: Armin Kuster <akuster808@gmail.com>
-rw-r--r--meta/recipes-devtools/perl/perl-native_5.20.0.bb4
1 files changed, 2 insertions, 2 deletions
diff --git a/meta/recipes-devtools/perl/perl-native_5.20.0.bb b/meta/recipes-devtools/perl/perl-native_5.20.0.bb
index 069696ae0c..01d40fcff2 100644
--- a/meta/recipes-devtools/perl/perl-native_5.20.0.bb
+++ b/meta/recipes-devtools/perl/perl-native_5.20.0.bb
@@ -103,8 +103,8 @@ do_install () {
install $i ${D}${libdir}/perl/${PV}/CORE
done
- create_wrapper ${D}${bindir}/perl PERL5LIB='$PERL5LIB:${STAGING_LIBDIR}/perl/${PV}:${STAGING_LIBDIR}/perl/'
- create_wrapper ${D}${bindir}/perl${PV} PERL5LIB='$PERL5LIB:${STAGING_LIBDIR}/perl/${PV}:${STAGING_LIBDIR}/perl/'
+ create_wrapper ${D}${bindir}/perl PERL5LIB='$PERL5LIB:${STAGING_LIBDIR}/perl/${PV}:${STAGING_LIBDIR}/perl:${STAGING_LIBDIR}/perl/site_perl/${PV}:${STAGING_LIBDIR}/perl/vendor_perl/${PV}'
+ create_wrapper ${D}${bindir}/perl${PV} PERL5LIB='$PERL5LIB:${STAGING_LIBDIR}/perl/${PV}:${STAGING_LIBDIR}/perl${STAGING_LIBDIR}/perl:${STAGING_LIBDIR}/perl/site_perl/${PV}:${STAGING_LIBDIR}/perl/vendor_perl/${PV}'
# Use /usr/bin/env nativeperl for the perl script.
for f in `grep -Il '#! *${bindir}/perl' ${D}/${bindir}/*`; do