aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorChong Lu <Chong.Lu@windriver.com>2014-10-27 13:24:23 +0800
committerRichard Purdie <richard.purdie@linuxfoundation.org>2014-12-31 10:17:09 +0000
commita6b79ecb502df0f935f5c8575ace9e781770e5c1 (patch)
tree49fcf6f4ef67769c9acd6581d237378a14181fa2
parent9884e4f872b9ff354832053c86842dd0d3b0c8b3 (diff)
downloadopenembedded-core-contrib-a6b79ecb502df0f935f5c8575ace9e781770e5c1.tar.gz
kmod: fix debuginfo is missing in shared library
INHIBIT_PACKAGE_STRIP variable will make debuginfo lose in shared library. The test cases of kmod contain kernel modules for many different architectures, strip and arch gets confused and throws errors. Pack kernel modules in test cases to avoid strip command failed. (From OE-Core rev: 3576399ed163cb3136ee1a2077622035d2033158) Signed-off-by: Chong Lu <Chong.Lu@windriver.com> Signed-off-by: Ross Burton <ross.burton@intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org> Signed-off-by: Armin Kuster <akuster808@gmail.com>
-rwxr-xr-xmeta/recipes-kernel/kmod/kmod/run-ptest2
-rw-r--r--meta/recipes-kernel/kmod/kmod_git.bb9
2 files changed, 10 insertions, 1 deletions
diff --git a/meta/recipes-kernel/kmod/kmod/run-ptest b/meta/recipes-kernel/kmod/kmod/run-ptest
index 37adec3d2f..598dd2cb5f 100755
--- a/meta/recipes-kernel/kmod/kmod/run-ptest
+++ b/meta/recipes-kernel/kmod/kmod/run-ptest
@@ -1,3 +1,5 @@
#!/bin/sh
touch testsuite/stamp-rootfs
+tar xf testmodule.tar
make -k runtest-TESTS 2>/dev/null| grep -e ^PASS -e ^FAIL
+find testsuite -name *.ko -exec rm -f {} \;
diff --git a/meta/recipes-kernel/kmod/kmod_git.bb b/meta/recipes-kernel/kmod/kmod_git.bb
index d4c21a4387..08dd81569c 100644
--- a/meta/recipes-kernel/kmod/kmod_git.bb
+++ b/meta/recipes-kernel/kmod/kmod_git.bb
@@ -34,6 +34,10 @@ do_install_append () {
# install depmod.d file for search/ dir
install -Dm644 "${WORKDIR}/depmod-search.conf" "${D}${base_libdir}/depmod.d/search.conf"
+ if ${@base_contains('DISTRO_FEATURES', 'ptest', 'true', 'false', d)}; then
+ find testsuite -name *.ko -exec tar rf testmodule.tar {} \;
+ find testsuite -name *.ko -exec rm -f {} \;
+ fi
}
do_compile_prepend() {
@@ -44,7 +48,10 @@ do_compile_ptest () {
oe_runmake buildtest-TESTS rootfs
}
-INHIBIT_PACKAGE_STRIP = "${@bb.utils.contains("DISTRO_FEATURES", "ptest", "1", "0", d)}"
+do_install_ptest () {
+ install testmodule.tar ${D}${PTEST_PATH}
+}
+
INSANE_SKIP_${PN}-ptest = "arch"
inherit update-alternatives