aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorOtavio Salvador <otavio@ossystems.com.br>2014-11-12 08:33:25 -0200
committerRichard Purdie <richard.purdie@linuxfoundation.org>2015-01-06 14:13:04 +0000
commit9936afa01866e1024770b9ad4c378b5ce93e8298 (patch)
tree64d8e6dc7d55ebf548e0e2ff20145f6290b9d852
parentd2b2d8c9ce3ef16ab053bd19a5705b01402b76ba (diff)
downloadopenembedded-core-contrib-9936afa01866e1024770b9ad4c378b5ce93e8298.tar.gz
sysvinit-inittab: Disable the carrier detect requirement for serial consoles
This aligns the params of getty with the ones used in Debian. From the getty(8) manpage: ,----[ getty(8) manpage ] | -L, --local-line | | Force the line to be a local line with no need for carrier | detect. This can be useful when you have a locally attached | terminal where the serial line does not set the carrier detect | signal. `---- Reported-by: Craig McQueen <craig.mcqueen@beamcommunications.com> (From OE-Core rev: a899c362be71cb7b94bd318c57702446b017005c) Signed-off-by: Otavio Salvador <otavio@ossystems.com.br> Tested-by: Craig McQueen <craig.mcqueen@beamcommunications.com> Signed-off-by: Ross Burton <ross.burton@intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org> Signed-off-by: Armin Kuster <akuster808@gmail.com>
-rw-r--r--meta/recipes-core/sysvinit/sysvinit-inittab_2.88dsf.bb2
1 files changed, 1 insertions, 1 deletions
diff --git a/meta/recipes-core/sysvinit/sysvinit-inittab_2.88dsf.bb b/meta/recipes-core/sysvinit/sysvinit-inittab_2.88dsf.bb
index c3244b4602..657ef02204 100644
--- a/meta/recipes-core/sysvinit/sysvinit-inittab_2.88dsf.bb
+++ b/meta/recipes-core/sysvinit/sysvinit-inittab_2.88dsf.bb
@@ -23,7 +23,7 @@ do_install() {
do
j=`echo ${i} | sed s/\;/\ /g`
label=`echo ${i} | sed -e 's/^.*;tty//' -e 's/;.*//'`
- echo "$label:12345:respawn:${base_sbindir}/getty ${j}" >> ${D}${sysconfdir}/inittab
+ echo "$label:12345:respawn:${base_sbindir}/getty -L ${j}" >> ${D}${sysconfdir}/inittab
done
if [ "${USE_VT}" = "1" ]; then