aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorWenzong Fan <wenzong.fan@windriver.com>2014-11-28 02:59:54 -0500
committerRichard Purdie <richard.purdie@linuxfoundation.org>2014-12-31 10:17:42 +0000
commit40de12333e05247ff52a5837fd55d61b38af3bf0 (patch)
treeb97e9109a116511b7ac77d61105796dd0810b965
parent9e147ac704a5ed148568e0deeb3df12475fab23c (diff)
downloadopenembedded-core-contrib-40de12333e05247ff52a5837fd55d61b38af3bf0.tar.gz
coreutils-native: don't install groups
This binary is provided by shadow-native nowadays. Fixes: ERROR: The recipe coreutils-native is trying to install files \ into a shared area when those files already exist. \ Those files and their manifest location are: \ .../tmp/sysroots/x86_64-linux/usr/bin/groups \ Matched in manifest-x86_64-shadow-native.populate_sysroot To reproduce the errors: $ bitbake shadow-native && bitbake coreutils-native (From OE-Core rev: 113225b93c55d55a330fcca7d9f996ec039fb953) Signed-off-by: Wenzong Fan <wenzong.fan@windriver.com> Signed-off-by: Ross Burton <ross.burton@intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org> Signed-off-by: Armin Kuster <akuster808@gmail.com>
-rw-r--r--meta/recipes-core/coreutils/coreutils_8.22.bb5
1 files changed, 5 insertions, 0 deletions
diff --git a/meta/recipes-core/coreutils/coreutils_8.22.bb b/meta/recipes-core/coreutils/coreutils_8.22.bb
index 6239600c6d..f85bacabd3 100644
--- a/meta/recipes-core/coreutils/coreutils_8.22.bb
+++ b/meta/recipes-core/coreutils/coreutils_8.22.bb
@@ -74,6 +74,11 @@ do_install_append() {
mv ${D}${bindir}/[ ${D}${bindir}/lbracket.${BPN}
}
+do_install_append_class-native(){
+ # remove groups to fix conflict with shadow-native
+ rm -f ${D}${STAGING_BINDIR_NATIVE}/groups
+}
+
inherit update-alternatives
ALTERNATIVE_PRIORITY = "100"