aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorChen Qi <Qi.Chen@windriver.com>2014-11-30 16:46:37 +0800
committerRichard Purdie <richard.purdie@linuxfoundation.org>2014-12-31 10:17:36 +0000
commit004ac11daf8f73aef68874d88dbc27301065aa83 (patch)
tree7103a3de2fa5ab73640dcb879ea2f3a933a49f72
parent47f6432dbc4e5315bed15e073c4b1359c181d227 (diff)
downloadopenembedded-core-contrib-004ac11daf8f73aef68874d88dbc27301065aa83.tar.gz
libxslt: create wrapper to avoid host system referencing
By default, xsltproc from libxslt would use configuration files under /etc/xml. To avoid host system contamination, we create a wrapper for this command to make it use configuration files in the sysroot directory. (From OE-Core rev: f14ecfa98baf98edf47b6820d3b0b3af376c5623) Signed-off-by: Chen Qi <Qi.Chen@windriver.com> Signed-off-by: Ross Burton <ross.burton@intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org> Signed-off-by: Armin Kuster <akuster808@gmail.com>
-rw-r--r--meta/recipes-support/libxslt/libxslt_1.1.28.bb5
1 files changed, 5 insertions, 0 deletions
diff --git a/meta/recipes-support/libxslt/libxslt_1.1.28.bb b/meta/recipes-support/libxslt/libxslt_1.1.28.bb
index 0b2526dbee..ded883e457 100644
--- a/meta/recipes-support/libxslt/libxslt_1.1.28.bb
+++ b/meta/recipes-support/libxslt/libxslt_1.1.28.bb
@@ -35,6 +35,11 @@ RPROVIDES_${PN}-bin += "${PN}-utils"
RCONFLICTS_${PN}-bin += "${PN}-utils"
RREPLACES_${PN}-bin += "${PN}-utils"
+
+do_install_append_class-native () {
+ create_wrapper ${D}/${bindir}/xsltproc XML_CATALOG_FILES=${sysconfdir}/xml/catalog.xml
+}
+
FILES_${PN} += "${libdir}/libxslt-plugins"
FILES_${PN}-dev += "${libdir}/xsltConf.sh"