aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorKai Kang <kai.kang@windriver.com>2015-02-16 10:41:14 +0800
committerRichard Purdie <richard.purdie@linuxfoundation.org>2015-03-16 17:38:44 +0000
commit9b25de34f084076b8c8db0e938696c4f630d366b (patch)
tree16cd4b34d52809bebea40ed55e0f876aba91bd14
parente1b837ab1e1d48b73217c4f62a0f5aefc998d8bf (diff)
downloadopenembedded-core-contrib-9b25de34f084076b8c8db0e938696c4f630d366b.tar.gz
msmtp: add link file /usr/lib/sendmail
Link file /usr/lib/sendmail points to /usr/sbin/sendmail is required by LSB core test according to Linux FHS: "For historical reasons, /usr/lib/sendmail must be a symbolic link to /usr/sbin/sendmail if the latter exists." Create the link file /usr/lib/sendmail if it doesn't exist. Refs: 1 http://refspecs.linuxfoundation.org/LSB_4.1.0/LSB-Core-generic/LSB-Core-generic/normativerefs.html#STD.LSB 2 http://www.pathname.com/fhs/pub/fhs-2.3.html#SPECIFICOPTIONS13 Signed-off-by: Kai Kang <kai.kang@windriver.com>
-rw-r--r--meta/recipes-extended/msmtp/msmtp_1.6.1.bb5
1 files changed, 5 insertions, 0 deletions
diff --git a/meta/recipes-extended/msmtp/msmtp_1.6.1.bb b/meta/recipes-extended/msmtp/msmtp_1.6.1.bb
index c9ad1da253..d6f3a1516f 100644
--- a/meta/recipes-extended/msmtp/msmtp_1.6.1.bb
+++ b/meta/recipes-extended/msmtp/msmtp_1.6.1.bb
@@ -23,3 +23,8 @@ ALTERNATIVE_${PN} = "sendmail"
ALTERNATIVE_TARGET[sendmail] = "${bindir}/msmtp"
ALTERNATIVE_LINK_NAME[sendmail] = "${sbindir}/sendmail"
ALTERNATIVE_PRIORITY = "100"
+
+pkg_postinst_${PN}_linuxstdbase () {
+ # /usr/lib/sendmial is required by LSB core test
+ [ ! -L $D/usr/lib/sendmail ] && ln -sf ${sbindir}/sendmail $D/usr/lib/
+}