summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorMax Tomago <max.tomago@codethink.co.uk>2019-10-15 17:37:44 +0100
committerRichard Purdie <richard.purdie@linuxfoundation.org>2019-10-19 23:18:26 +0100
commitbdc62e2845fc242cf0778623690fadcb8da731d4 (patch)
treee7afe87b44a010c1e44a0cdc9a8298514c5cd7e9
parent3b788da31af6296a0404ed6080aef17708d61303 (diff)
downloadopenembedded-core-contrib-bdc62e2845fc242cf0778623690fadcb8da731d4.tar.gz
python-native: Remove debug.patch
It doesn't look like it should be there. Signed-off-by: Max Tomago <max.tomago@codethink.co.uk> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
-rw-r--r--meta/recipes-devtools/python/python-native/debug.patch32
-rw-r--r--meta/recipes-devtools/python/python-native_2.7.16.bb1
2 files changed, 0 insertions, 33 deletions
diff --git a/meta/recipes-devtools/python/python-native/debug.patch b/meta/recipes-devtools/python/python-native/debug.patch
deleted file mode 100644
index 3617882640..0000000000
--- a/meta/recipes-devtools/python/python-native/debug.patch
+++ /dev/null
@@ -1,32 +0,0 @@
-Upstream-Status: Pending
-
-Index: Python-2.7.12/Lib/distutils/unixccompiler.py
-===================================================================
---- Python-2.7.12.orig/Lib/distutils/unixccompiler.py
-+++ Python-2.7.12/Lib/distutils/unixccompiler.py
-@@ -278,6 +278,8 @@ class UnixCCompiler(CCompiler):
-
-
-
-+ print "Looking in %s for %s" % (lib, dirs)
-+
- for dir in dirs:
- shared = os.path.join(dir, shared_f)
- dylib = os.path.join(dir, dylib_f)
-@@ -298,12 +300,16 @@ class UnixCCompiler(CCompiler):
- # assuming that *all* Unix C compilers do. And of course I'm
- # ignoring even GCC's "-static" option. So sue me.
- if os.path.exists(dylib):
-+ print "Found %s" % (dylib)
- return dylib
- elif os.path.exists(xcode_stub):
-+ print "Found %s" % (xcode_stub)
- return xcode_stub
- elif os.path.exists(shared):
-+ print "Found %s" % (shared)
- return shared
- elif os.path.exists(static):
-+ print "Found %s" % (static)
- return static
-
- # Oops, didn't find it in *any* of 'dirs'
diff --git a/meta/recipes-devtools/python/python-native_2.7.16.bb b/meta/recipes-devtools/python/python-native_2.7.16.bb
index b7442800d9..90103af8be 100644
--- a/meta/recipes-devtools/python/python-native_2.7.16.bb
+++ b/meta/recipes-devtools/python/python-native_2.7.16.bb
@@ -7,7 +7,6 @@ SRC_URI += "\
file://10-distutils-fix-swig-parameter.patch \
file://11-distutils-never-modify-shebang-line.patch \
file://0001-distutils-set-the-prefix-to-be-inside-staging-direct.patch \
- file://debug.patch \
file://unixccompiler.patch \
file://nohostlibs.patch \
file://multilib.patch \