summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorAdrian Bunk <bunk@stusta.de>2019-10-31 14:28:14 +0200
committerRichard Purdie <richard.purdie@linuxfoundation.org>2019-10-31 16:07:29 +0000
commit992cec44ad2073cfe05cb2c58936032af189748a (patch)
tree27a889a92898fbf748d6533ff45702da9a7c09eb
parentedb7f0adc6b0846c118ea262bbfaf46050c03fb4 (diff)
downloadopenembedded-core-contrib-992cec44ad2073cfe05cb2c58936032af189748a.tar.gz
coreutils: Move stdbuf into an own package coreutils-stdbuf
The coreutils implementation of stdbuf uses LD_PRELOAD to dynamically load libstdbuf which calls setvbuf(). This can't be implemented simply in busybox since it produces one or two statically linked executables. Therefore, stdbuf should be packaged separately for people who are using busybox instead of coreutils for the other tools. coreutils depends on the new package, so nothing changes when installing coreutils. Signed-off-by: Adrian Bunk <bunk@stusta.de> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
-rw-r--r--meta/recipes-core/coreutils/coreutils_8.31.bb6
1 files changed, 5 insertions, 1 deletions
diff --git a/meta/recipes-core/coreutils/coreutils_8.31.bb b/meta/recipes-core/coreutils/coreutils_8.31.bb
index 4a74f619af..57b2c1bdba 100644
--- a/meta/recipes-core/coreutils/coreutils_8.31.bb
+++ b/meta/recipes-core/coreutils/coreutils_8.31.bb
@@ -49,7 +49,7 @@ bindir_progs = "arch basename chcon cksum comm csplit cut dir dircolors dirname
env expand expr factor fmt fold groups head hostid id install \
join link logname md5sum mkfifo nl nohup nproc od paste pathchk \
pinky pr printf ptx readlink realpath runcon seq sha1sum sha224sum sha256sum \
- sha384sum sha512sum shred shuf sort split stdbuf sum tac tail tee test timeout \
+ sha384sum sha512sum shred shuf sort split sum tac tail tee test timeout \
tr truncate tsort tty unexpand uniq unlink uptime users vdir wc who whoami yes"
# hostname gets a special treatment and is not included in this
@@ -58,6 +58,10 @@ base_bindir_progs = "cat chgrp chmod chown cp date dd echo false hostname kill l
sbindir_progs= "chroot"
+PACKAGE_BEFORE_PN_class-target += "coreutils-stdbuf"
+FILES_coreutils-stdbuf = "${bindir}/stdbuf ${libdir}/coreutils/libstdbuf.so"
+RDEPENDS_coreutils_class-target += "coreutils-stdbuf"
+
# Let aclocal use the relative path for the m4 file rather than the
# absolute since coreutils has a lot of m4 files, otherwise there might
# be an "Argument list too long" error when it is built in a long/deep