summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRoss Burton <ross.burton@intel.com>2019-11-04 12:14:57 +0000
committerRichard Purdie <richard.purdie@linuxfoundation.org>2019-11-05 10:36:19 +0000
commit03591b9945bf04baca794e221b93ac66568b0609 (patch)
tree3851277b1cbe89af97ed57ddbb6f6946b63020da
parent1ab9fc04d6666de0c5c176f546f64c11dffe2106 (diff)
downloadopenembedded-core-contrib-03591b9945bf04baca794e221b93ac66568b0609.tar.gz
file: run test suite when building natively
As we apply the same patches to native and target builds of file, we can verify that the patches are not breaking by executing the test suite during the build of file-native. Signed-off-by: Ross Burton <ross.burton@intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
-rw-r--r--meta/recipes-devtools/file/file_5.37.bb4
1 files changed, 4 insertions, 0 deletions
diff --git a/meta/recipes-devtools/file/file_5.37.bb b/meta/recipes-devtools/file/file_5.37.bb
index 80e8b91058..a96ccc0d39 100644
--- a/meta/recipes-devtools/file/file_5.37.bb
+++ b/meta/recipes-devtools/file/file_5.37.bb
@@ -29,6 +29,10 @@ EXTRA_OEMAKE_append_class-nativesdk = "-e FILE_COMPILE=${STAGING_BINDIR_NATIVE}/
FILES_${PN} += "${datadir}/misc/*.mgc"
+do_compile_append_class-native() {
+ oe_runmake check
+}
+
do_install_append_class-native() {
create_cmdline_wrapper ${D}/${bindir}/file \
--magic-file ${datadir}/misc/magic.mgc