aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRichard Purdie <richard.purdie@linuxfoundation.org>2018-10-16 10:51:18 +0100
committerRichard Purdie <richard.purdie@linuxfoundation.org>2018-10-16 20:25:37 +0100
commit74833a612cc383679bb5516e98c7508da47b0767 (patch)
tree94e0ae43e5bde6b7096fd6b2478e29c04ea8c16a
parentd7f828223f3fabdadcff974c1ed6f8f74e438405 (diff)
downloadopenembedded-core-contrib-74833a612cc383679bb5516e98c7508da47b0767.tar.gz
systemtap: Fix issues from 4.0 upgrade
4.0 adds systemd support but installs the unit files in the wrong location. Fix this in do_install and inherit systemd to package them correctly. Also fix ownership of files manually copied in to root:root to avoid QA warnings. Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
-rw-r--r--meta/recipes-kernel/systemtap/systemtap_git.bb10
1 files changed, 9 insertions, 1 deletions
diff --git a/meta/recipes-kernel/systemtap/systemtap_git.bb b/meta/recipes-kernel/systemtap/systemtap_git.bb
index 0b7833e901..3c45bfa937 100644
--- a/meta/recipes-kernel/systemtap/systemtap_git.bb
+++ b/meta/recipes-kernel/systemtap/systemtap_git.bb
@@ -25,7 +25,7 @@ PACKAGECONFIG[sqlite] = "--enable-sqlite,--disable-sqlite,sqlite3"
PACKAGECONFIG[monitor] = "--enable-monitor,--disable-monitor,ncurses json-c"
PACKAGECONFIG[python3-probes] = "--with-python3-probes,--without-python3-probes,python3-setuptools-native"
-inherit autotools gettext pkgconfig distutils3-base
+inherit autotools gettext pkgconfig distutils3-base systemd
do_configure_prepend () {
# Improve reproducibility for c++ object files
@@ -39,6 +39,14 @@ do_install_append () {
rm -rf ${D}${datadir}/${PN}
rm ${D}${libexecdir}/${PN}/stap-env
fi
+
+ # Fix makefile hardcoded path assumptions for systemd (assumes $prefix)
+ install -d `dirname ${D}${systemd_unitdir}`
+ mv ${D}${prefix}/lib/systemd `dirname ${D}${systemd_unitdir}`
+ rmdir ${D}${prefix}/lib --ignore-fail-on-non-empty
+
+ # Ensure correct ownership for files copied in
+ chown root.root ${D}${sysconfdir}/stap-exporter/* -R
}
BBCLASSEXTEND = "nativesdk"