summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorJoshua Watt <jpewhacker@gmail.com>2020-08-12 19:37:03 -0500
committerRichard Purdie <richard.purdie@linuxfoundation.org>2020-08-13 14:49:39 +0100
commit140ec7b71b71a23ebeae12c63ed1c1ac2c227097 (patch)
tree2ddc4a8383954ebe62b1311b5bb497b70e9cd4c7
parentddbe09b0f9861fe3012611b5a5298eb4d7c4df45 (diff)
downloadopenembedded-core-contrib-140ec7b71b71a23ebeae12c63ed1c1ac2c227097.tar.gz
perl: Add check for non-arch Storable.pm file
Under unknown conditions, Storable.pm will be placed in the base library directory instead of under the arch specific one. This causes build issues, see https://bugzilla.yoctoproject.org/show_bug.cgi?id=13946. To try and catch this happening, add an explicit check for the bad file existing and fail the build if it is found. [YOCTO #13946] Signed-off-by: Joshua Watt <JPEWhacker@gmail.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
-rw-r--r--meta/recipes-devtools/perl/perl_5.32.0.bb5
1 files changed, 5 insertions, 0 deletions
diff --git a/meta/recipes-devtools/perl/perl_5.32.0.bb b/meta/recipes-devtools/perl/perl_5.32.0.bb
index c10ce12303..bba8263b90 100644
--- a/meta/recipes-devtools/perl/perl_5.32.0.bb
+++ b/meta/recipes-devtools/perl/perl_5.32.0.bb
@@ -139,6 +139,11 @@ do_install() {
# Fix up shared library
rm ${D}/${libdir}/perl5/${PV}/*/CORE/libperl.so
ln -sf ../../../../libperl.so.${PERL_LIB_VER} $(echo ${D}/${libdir}/perl5/${PV}/*/CORE)/libperl.so
+
+ # Try to catch Bug #13946
+ if [ -e ${D}/${libdir}/perl5/${PV}/Storable.pm ]; then
+ bbfatal 'non-arch specific Storable.pm found! See https://bugzilla.yoctoproject.org/show_bug.cgi?id=13946'
+ fi
}
do_install_append_class-target() {