summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorAlexander Kanavin <alex.kanavin@gmail.com>2021-10-11 11:40:44 +0200
committerRichard Purdie <richard.purdie@linuxfoundation.org>2021-10-14 11:48:35 +0100
commit7a477de350eaf7095745db81fb03e7ab20188f5a (patch)
tree5a09f3bf934f5f86c170d75edb812b9ae4607cb4
parent02a66905fa48402589e1799deed2a7f32896525a (diff)
downloadopenembedded-core-contrib-7a477de350eaf7095745db81fb03e7ab20188f5a.tar.gz
ruby: disable openssl extension
It is incompatible with openssl 3 in currently released versions, and given very marginal use of ruby in oe, I do not think not having it matters. Signed-off-by: Alexander Kanavin <alex@linutronix.de> Signed-off-by: Alexandre Belloni <alexandre.belloni@bootlin.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
-rw-r--r--meta/recipes-devtools/ruby/ruby.inc5
1 files changed, 5 insertions, 0 deletions
diff --git a/meta/recipes-devtools/ruby/ruby.inc b/meta/recipes-devtools/ruby/ruby.inc
index c953a27042..2b5caf35f5 100644
--- a/meta/recipes-devtools/ruby/ruby.inc
+++ b/meta/recipes-devtools/ruby/ruby.inc
@@ -37,3 +37,8 @@ do_configure:prepend() {
sed -i "s#%%TARGET_CFLAGS%%#$CFLAGS#; s#%%TARGET_LDFLAGS%%#$LDFLAGS#" ${S}/common.mk
rm -rf ${S}/ruby/
}
+
+# Disable openssl extension until it becomes compatible with openssl 3
+do_configure:prepend() {
+ rm -rf ${S}/ext/openssl/extconf.rb
+}