summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorLei Maohui <leimaohui@fujitsu.com>2024-04-18 09:22:47 +0800
committerAlexandre Belloni <alexandre.belloni@bootlin.com>2024-04-21 22:41:26 +0200
commit01c4d6ec442a8a22c37ae1d9ed3760e7351267f4 (patch)
treef9594116b01f8363c81f5f3eed34c767e1978cd2
parentd50bae8c9ddb59d0c026522f9fe92bf1672c0296 (diff)
downloadopenembedded-core-contrib-01c4d6ec442a8a22c37ae1d9ed3760e7351267f4.tar.gz
libbsd: Fix conflict error when enable multilib.
- The conflict error is as the following: Error: Transaction test error: file /usr/include/bsd/sys/cdefs.h conflicts between attempted installs of libbsd-dev-0.12.1-r0.core2_64 and lib32-libbsd-dev-0.12.1-r0.core2_32 The difference of bsd/sys/cdefs.h between libbsd-dev and lib32-libbsd-dev is as following: /* Define the ABI for the current system. */ -#define LIBBSD_SYS_TIME_BITS 64 +#define LIBBSD_SYS_TIME_BITS 32 #define LIBBSD_SYS_HAS_TIME64 1 - The path of cdefs-64.h and cdefs-32.h in cdefs.h is not correct for libbsd after enable oe_multilib_header on cdefs.h. It is necessary to fix the path. Signed-off-by: Lei Maohui <leimaohui@fujitsu.com> Signed-off-by: Alexandre Belloni <alexandre.belloni@bootlin.com>
-rw-r--r--meta/recipes-support/libbsd/libbsd_0.12.2.bb8
1 files changed, 7 insertions, 1 deletions
diff --git a/meta/recipes-support/libbsd/libbsd_0.12.2.bb b/meta/recipes-support/libbsd/libbsd_0.12.2.bb
index 7d5e88f293..e1fc7d9b3c 100644
--- a/meta/recipes-support/libbsd/libbsd_0.12.2.bb
+++ b/meta/recipes-support/libbsd/libbsd_0.12.2.bb
@@ -40,8 +40,14 @@ SRC_URI = "https://libbsd.freedesktop.org/releases/${BPN}-${PV}.tar.xz"
SRC_URI[sha256sum] = "b88cc9163d0c652aaf39a99991d974ddba1c3a9711db8f1b5838af2a14731014"
-inherit autotools pkgconfig
+inherit autotools pkgconfig multilib_header
DEPENDS += "libmd"
+do_install:append () {
+ oe_multilib_header bsd/sys/cdefs.h
+ sed -i 's:#include <bsd/sys/cdefs:#include <sys/cdefs:g' ${D}${includedir}/bsd/sys/cdefs.h
+}
+
+
BBCLASSEXTEND = "native nativesdk"