aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2015-03-05 01:23:49 +0000
committerRichard Purdie <richard.purdie@linuxfoundation.org>2015-03-09 16:05:05 +0000
commit9c2eb7f4774356fabf21ff5147a7d34601fb57c8 (patch)
tree4e860abd122cdf192d384d6b3f7361f8f994a8cd
parentb75e23568d72aea3c508492c129c361bedd98eb4 (diff)
downloadopenembedded-core-contrib-9c2eb7f4774356fabf21ff5147a7d34601fb57c8.tar.gz
systemd: Create packageconfig for ldconfig support
Useful when we disable ldconfig in glibc, we need to be able to turn it off in systemd too, otherwise systemd tries to launch the service and it fails Change-Id: I170307f809a13def0cafc282e88d4eafa0313c31 Signed-off-by: Khem Raj <raj.khem@gmail.com> Signed-off-by: Ross Burton <ross.burton@intel.com>
-rw-r--r--meta/recipes-core/systemd/systemd_219.bb3
1 files changed, 2 insertions, 1 deletions
diff --git a/meta/recipes-core/systemd/systemd_219.bb b/meta/recipes-core/systemd/systemd_219.bb
index 95b3f49148..454268a33a 100644
--- a/meta/recipes-core/systemd/systemd_219.bb
+++ b/meta/recipes-core/systemd/systemd_219.bb
@@ -58,7 +58,7 @@ LDFLAGS_append_libc-uclibc = " -lrt"
GTKDOC_DOCDIR = "${S}/docs/"
-PACKAGECONFIG ??= "xz \
+PACKAGECONFIG ??= "xz ldconfig \
${@bb.utils.contains('DISTRO_FEATURES', 'pam', 'pam', '', d)} \
${@bb.utils.contains('DISTRO_FEATURES', 'x11', 'xkbcommon', '', d)}"
@@ -83,6 +83,7 @@ PACKAGECONFIG[pam] = "--enable-pam,--disable-pam,libpam"
PACKAGECONFIG[xkbcommon] = "--enable-xkbcommon,--disable-xkbcommon,libxkbcommon"
# Update NAT firewall rules
PACKAGECONFIG[iptc] = "--enable-libiptc,--disable-libiptc,iptables"
+PACKAGECONFIG[ldconfig] = "--enable-ldconfig,--disable-ldconfig,,"
CACHED_CONFIGUREVARS = "ac_cv_path_KILL=${base_bindir}/kill"