aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRobert Yang <liezhi.yang@windriver.com>2014-09-02 02:41:49 -0700
committerRichard Purdie <richard.purdie@linuxfoundation.org>2014-09-03 10:24:20 +0100
commitece99c85c27a546ea59a78875f630e82270c3177 (patch)
treed00dde2e937c4f9a54ebb46ebd7c1c59b1c85383
parent928fc6c3652ba5db87e1f1c7923972d85c31bc08 (diff)
downloadopenembedded-core-contrib-ece99c85c27a546ea59a78875f630e82270c3177.tar.gz
piglit: add bash to RDEPENDS_piglit
Bash: piglit/usr/lib/piglit/tests/asmparsertest/make_test_list.sh:#!/bin/bash piglit/usr/lib/piglit/tests/asmparsertest/vp-tex.sh:#!/bin/bash piglit/usr/lib/piglit/tests/spec/glsl-1.10/variable-index-read.sh:#!/bin/bash piglit/usr/lib/piglit/tests/spec/glsl-1.10/variable-index-write.sh:#!/bin/bash piglit/usr/lib/piglit/tests/spec/arb_shader_texture_lod/compiler/make_tex_lod_tests.sh:#!/bin/bash piglit/usr/lib/piglit/tests/spec/glsl-1.20/execution/outerProduct-const.sh:#!/bin/bash piglit/usr/lib/piglit/tests/spec/glsl-1.20/execution/outerProduct.sh:#!/bin/bash piglit/usr/lib/piglit/tests/spec/glsl-1.20/compiler/built-in-functions/outerProduct-invalid-parameters.sh:#!/bin/bash piglit/usr/lib/piglit/tests/glslparsertest/glsl2/make_tex_lod_tests.sh:#!/bin/bash piglit/usr/lib/piglit/tests/glslparsertest/glsl2/make_tex_rect_tests.sh:#!/bin/bash The bash scripts are in the tests directory, we had planned to move the tests into the ptest pkg, but that would make piglit unusable without installing piglit-ptest. Signed-off-by: Robert Yang <liezhi.yang@windriver.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
-rw-r--r--meta/recipes-graphics/piglit/piglit_git.bb5
1 files changed, 4 insertions, 1 deletions
diff --git a/meta/recipes-graphics/piglit/piglit_git.bb b/meta/recipes-graphics/piglit/piglit_git.bb
index 5c013ef94f..f468120f80 100644
--- a/meta/recipes-graphics/piglit/piglit_git.bb
+++ b/meta/recipes-graphics/piglit/piglit_git.bb
@@ -45,4 +45,7 @@ do_install() {
FILES_${PN}-dbg += "${libdir}/piglit/*/.debug/"
-RDEPENDS_${PN} = "python waffle python-json python-subprocess python-multiprocessing python-textutils python-netserver python-shell mesa-demos"
+RDEPENDS_${PN} = "python waffle python-json python-subprocess \
+ python-multiprocessing python-textutils python-netserver python-shell \
+ mesa-demos bash \
+ "