aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorWang Zidan <b50113@freescale.com>2014-07-22 14:49:22 +0800
committerRichard Purdie <richard.purdie@linuxfoundation.org>2014-07-23 21:44:22 +0100
commite25c5b228178f13b2f9e25b5bd423d5ef7b40765 (patch)
treef13e04e4e09ddcecb617728adbb34eb32486d437
parent81ae7794ddbc7e2d97118092e0613249793214ef (diff)
downloadopenembedded-core-contrib-e25c5b228178f13b2f9e25b5bd423d5ef7b40765.tar.gz
gstreamer1.0: pass rate of input segment to output segment in gstbaseparse.
Signed-off-by: Wang Zidan <b50113@freescale.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
-rw-r--r--meta/recipes-multimedia/gstreamer/gstreamer1.0/0001-pass-rate-of-input-segment-to-output-segment.patch32
-rw-r--r--meta/recipes-multimedia/gstreamer/gstreamer1.0_1.2.4.bb4
2 files changed, 35 insertions, 1 deletions
diff --git a/meta/recipes-multimedia/gstreamer/gstreamer1.0/0001-pass-rate-of-input-segment-to-output-segment.patch b/meta/recipes-multimedia/gstreamer/gstreamer1.0/0001-pass-rate-of-input-segment-to-output-segment.patch
new file mode 100644
index 0000000000..be6c834df2
--- /dev/null
+++ b/meta/recipes-multimedia/gstreamer/gstreamer1.0/0001-pass-rate-of-input-segment-to-output-segment.patch
@@ -0,0 +1,32 @@
+From e70334442ba3bb046a6389bb3d8549323dc1e7f0 Mon Sep 17 00:00:00 2001
+From: zhouming <zmafox@gmail.com>
+Date: Wed, 7 May 2014 18:26:38 +0800
+Subject: [PATCH] pass rate of input segment to output segment.
+
+https://bugzilla.gnome.org/show_bug.cgi?id=729701
+
+Commit - 2793f808ee7fbebc7de2c7b733c6e94dac6a099f in master branch
+
+Upstream Status: Backported
+
+Signed-off-by: <zmafox@gmail.com>
+---
+ libs/gst/base/gstbaseparse.c | 2 ++
+ 1 file changed, 2 insertions(+)
+
+diff --git a/libs/gst/base/gstbaseparse.c b/libs/gst/base/gstbaseparse.c
+index 4378cad..7579b5e 100644
+--- a/libs/gst/base/gstbaseparse.c
++++ b/libs/gst/base/gstbaseparse.c
+@@ -1012,6 +1012,8 @@ gst_base_parse_sink_event_default (GstBaseParse * parse, GstEvent * event)
+
+ gst_event_parse_segment (event, &in_segment);
+ gst_segment_init (&out_segment, GST_FORMAT_TIME);
++ out_segment.rate = in_segment->rate;
++ out_segment.applied_rate = in_segment->applied_rate;
+
+ GST_DEBUG_OBJECT (parse, "segment %" GST_SEGMENT_FORMAT, in_segment);
+
+--
+1.7.9.5
+
diff --git a/meta/recipes-multimedia/gstreamer/gstreamer1.0_1.2.4.bb b/meta/recipes-multimedia/gstreamer/gstreamer1.0_1.2.4.bb
index 1204dd5fa3..535b681bb3 100644
--- a/meta/recipes-multimedia/gstreamer/gstreamer1.0_1.2.4.bb
+++ b/meta/recipes-multimedia/gstreamer/gstreamer1.0_1.2.4.bb
@@ -6,7 +6,9 @@ LIC_FILES_CHKSUM = "file://COPYING;md5=6762ed442b3822387a51c92d928ead0d \
SRC_URI = " \
http://gstreamer.freedesktop.org/src/gstreamer/gstreamer-${PV}.tar.xz \
file://0001-Fix-crash-with-gst-inspect.patch \
- "
+ file://0001-pass-rate-of-input-segment-to-output-segment.patch \
+"
+
SRC_URI[md5sum] = "74d8f674187a5f0ddf38da594c3998c3"
SRC_URI[sha256sum] = "1e7ca67a7870a82c9ed51d51d0008cdbc550c41d64cc3ff3f9a1c2fc311b4929"
S = "${WORKDIR}/gstreamer-${PV}"