aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorWang Zidan <b50113@freescale.com>2014-07-22 14:49:23 +0800
committerRichard Purdie <richard.purdie@linuxfoundation.org>2014-07-23 21:44:22 +0100
commit8b85075e592e867e7ffba919b10fca150f6a62b0 (patch)
treef9ee8f49626b2baf18fe4fea33e33743b39c8cac
parente25c5b228178f13b2f9e25b5bd423d5ef7b40765 (diff)
downloadopenembedded-core-contrib-8b85075e592e867e7ffba919b10fca150f6a62b0.tar.gz
gstreamer1.0-plugins-base: do not change eos event to gap event if no data has passed to streamsynchronizer.
Signed-off-by: Wang Zidan <b50113@freescale.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
-rw-r--r--meta/recipes-multimedia/gstreamer/gstreamer1.0-plugins-base/do-not-change-eos-event-to-gap-event-if.patch37
-rw-r--r--meta/recipes-multimedia/gstreamer/gstreamer1.0-plugins-base_1.2.4.bb4
2 files changed, 41 insertions, 0 deletions
diff --git a/meta/recipes-multimedia/gstreamer/gstreamer1.0-plugins-base/do-not-change-eos-event-to-gap-event-if.patch b/meta/recipes-multimedia/gstreamer/gstreamer1.0-plugins-base/do-not-change-eos-event-to-gap-event-if.patch
new file mode 100644
index 0000000000..0407a30f90
--- /dev/null
+++ b/meta/recipes-multimedia/gstreamer/gstreamer1.0-plugins-base/do-not-change-eos-event-to-gap-event-if.patch
@@ -0,0 +1,37 @@
+From b608d027fff6efc2d1988ebf169cbe3b2b44a61b Mon Sep 17 00:00:00 2001
+From: zhouming <b42586@freescale.com>
+Date: Thu, 8 May 2014 12:01:17 +0800
+Subject: [PATCH] ENGR00312034: do not change eos event to gap event if no
+ data has passed to streamsynchronizer.
+
+https://bugzilla.gnome.org/show_bug.cgi?id=727074
+
+Upstream Status: Pending
+
+Signed-off-by: zhouming <b42586@freescale.com>
+---
+ gst/playback/gststreamsynchronizer.c | 5 ++---
+ 1 file changed, 2 insertions(+), 3 deletions(-)
+
+diff --git a/gst/playback/gststreamsynchronizer.c b/gst/playback/gststreamsynchronizer.c
+index 3997d1b..3e17c55 100644
+--- a/gst/playback/gststreamsynchronizer.c
++++ b/gst/playback/gststreamsynchronizer.c
+@@ -488,12 +488,11 @@ gst_stream_synchronizer_sink_event (GstPad * pad, GstObject * parent,
+ }
+ g_slist_free (pads);
+ } else {
+- /* if EOS, but no data has passed, then send something to replace EOS
+- * for preroll purposes */
++ /* if EOS, but no data has passed, then send EOS event */
+ if (!seen_data) {
+ GstEvent *gap_event;
+
+- gap_event = gst_event_new_gap (timestamp, GST_CLOCK_TIME_NONE);
++ gap_event = gst_event_new_eos ();
+ ret = gst_pad_push_event (srcpad, gap_event);
+ } else {
+ GstEvent *gap_event;
+--
+1.7.9.5
+
diff --git a/meta/recipes-multimedia/gstreamer/gstreamer1.0-plugins-base_1.2.4.bb b/meta/recipes-multimedia/gstreamer/gstreamer1.0-plugins-base_1.2.4.bb
index ed8babe2a0..6e3d8f9833 100644
--- a/meta/recipes-multimedia/gstreamer/gstreamer1.0-plugins-base_1.2.4.bb
+++ b/meta/recipes-multimedia/gstreamer/gstreamer1.0-plugins-base_1.2.4.bb
@@ -4,6 +4,10 @@ LIC_FILES_CHKSUM = "file://COPYING;md5=c54ce9345727175ff66d17b67ff51f58 \
file://common/coverage/coverage-report.pl;beginline=2;endline=17;md5=a4e1830fce078028c8f0974161272607 \
file://COPYING.LIB;md5=6762ed442b3822387a51c92d928ead0d \
"
+
+SRC_URI += "file://do-not-change-eos-event-to-gap-event-if.patch \
+"
+
SRC_URI[md5sum] = "278e0a1872ecb981e91830b2cb7f3e98"
SRC_URI[sha256sum] = "4d6273dc3f5a94bcc53ccfe0711cfddd49e31371d1136bf62fa1ecc604fc6550"
S = "${WORKDIR}/gst-plugins-base-${PV}"