aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRobert P. J. Day <rpjday@crashcourse.ca>2014-07-08 21:58:42 +0300
committerRichard Purdie <richard.purdie@linuxfoundation.org>2014-07-21 11:00:57 +0100
commitaf4f1f4a9846c7b2692f603494d8a40e1f5df1b7 (patch)
tree4e88c29d4e03ba614017e2119be18f06e53e71f6
parent696973af240cbe0122189178895074adf0d643f4 (diff)
downloadopenembedded-core-contrib-af4f1f4a9846c7b2692f603494d8a40e1f5df1b7.tar.gz
bitbake: bitbake-user-manual-execution.xml: Minor edits to execution chapter.
(Bitbake rev: 8ff1b363df74f7e48da67fce9cf6b7e868c5e28e) Signed-off-by: Scott Rifenbark <scott.m.rifenbark@intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
-rw-r--r--bitbake/doc/bitbake-user-manual/bitbake-user-manual-execution.xml31
1 files changed, 30 insertions, 1 deletions
diff --git a/bitbake/doc/bitbake-user-manual/bitbake-user-manual-execution.xml b/bitbake/doc/bitbake-user-manual/bitbake-user-manual-execution.xml
index 8b6e0b442f..571424b99f 100644
--- a/bitbake/doc/bitbake-user-manual/bitbake-user-manual-execution.xml
+++ b/bitbake/doc/bitbake-user-manual/bitbake-user-manual-execution.xml
@@ -7,7 +7,8 @@
<para>
The primary purpose for running BitBake is to produce some kind
of output such as a single installable package, a kernel, a software
- development kit, or even a full, board-specific bootable Linux image.
+ development kit, or even a full, board-specific bootable Linux image,
+ complete with bootloader, kernel, and root filesystem.
Of course, you can execute the <filename>bitbake</filename>
command with options that cause it to execute single tasks,
compile single recipe files, capture or clear data, or simply
@@ -45,6 +46,11 @@
build host with hyper-threading will most likely show eight processors,
which is the value you would then assign to that variable.
</para>
+
+ <para>
+ A possibly simpler solution is that some Linux distributions
+ (e.g. Debian and Ubuntu) provide the <filename>ncpus</filename> command.
+ </para>
</note>
</para>
@@ -464,6 +470,29 @@
PREFERRED_VERSION_a = "1.1"
</literallayout>
</para>
+
+ <note>
+ <para>
+ It is common for a recipe to provide two versions -- a stable,
+ numbered (and preferred) version, and a version that is
+ automatically checked out from a source code repository that
+ is considered more "bleeding edge" but can be selected only
+ explicitly.
+ </para>
+
+ <para>
+ For example, in the OpenEmbedded codebase, there is a standard,
+ versioned recipe file for BusyBox,
+ <filename>busybox_1.22.1.bb</filename>,
+ but there is also a Git-based version,
+ <filename>busybox_git.bb</filename>, which explicitly contains the line
+ <literallayout class='monospaced'>
+ DEFAULT_PREFERENCE = "-1"
+ </literallayout>
+ to ensure that the numbered, stable version is always preferred
+ unless the developer selects otherwise.
+ </para>
+ </note>
</section>
<section id='bb-bitbake-dependencies'>