aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorJoe Slater <jslater@windriver.com>2014-09-12 12:20:22 -0700
committerRichard Purdie <richard.purdie@linuxfoundation.org>2014-09-16 22:12:29 +0100
commit09610d6cdda95e964a7565b13eb35a26ae652aa9 (patch)
tree2aab3693b94f71f5d01ddaabef991016d1221d98
parentda120dec96f8f019c0fd50576fb7490689234257 (diff)
downloadopenembedded-core-contrib-09610d6cdda95e964a7565b13eb35a26ae652aa9.tar.gz
at-spi2-core: fix DBIND_CHECK_ALIGNOF m4 macro
Modify the macro so it will work when cross-compiling. Note that the values checked are normally in a site file so the macro rarely has to discover them. Signed-off-by: Joe Slater <jslater@windriver.com> Signed-off-by: Ross Burton <ross.burton@intel.com>
-rw-r--r--meta/recipes-support/atk/at-spi2-core_2.12.0.bb5
-rw-r--r--meta/recipes-support/atk/files/core_acinclude_m4.patch40
2 files changed, 44 insertions, 1 deletions
diff --git a/meta/recipes-support/atk/at-spi2-core_2.12.0.bb b/meta/recipes-support/atk/at-spi2-core_2.12.0.bb
index 31e133fe43..e67155ccbd 100644
--- a/meta/recipes-support/atk/at-spi2-core_2.12.0.bb
+++ b/meta/recipes-support/atk/at-spi2-core_2.12.0.bb
@@ -4,7 +4,10 @@ LIC_FILES_CHKSUM = "file://COPYING;md5=e9f288ba982d60518f375b5898283886"
MAJ_VER = "${@oe.utils.trim_version("${PV}", 2)}"
-SRC_URI = "${GNOME_MIRROR}/${BPN}/${MAJ_VER}/${BPN}-${PV}.tar.xz"
+SRC_URI = "${GNOME_MIRROR}/${BPN}/${MAJ_VER}/${BPN}-${PV}.tar.xz \
+ file://core_acinclude_m4.patch \
+ "
+
SRC_URI[md5sum] = "b12ad0e0924706f5e7f51216241068ef"
SRC_URI[sha256sum] = "db550edd98e53b4252521459c2dcaf0f3b060a9bad52489b9dbadbaedad3fb89"
diff --git a/meta/recipes-support/atk/files/core_acinclude_m4.patch b/meta/recipes-support/atk/files/core_acinclude_m4.patch
new file mode 100644
index 0000000000..29c538e2c3
--- /dev/null
+++ b/meta/recipes-support/atk/files/core_acinclude_m4.patch
@@ -0,0 +1,40 @@
+at-spi2-core: fix alignof m4 macro
+
+DBIND_CHECK_ALIGNOF does not work when cross-compiling, so we modify
+it to use AC_CHECK_ALIGNOF.
+
+Upstream-Status: Pending
+
+Signed-off-by: joe.slater@windriver.com
+
+
+--- a/acinclude.m4
++++ b/acinclude.m4
+@@ -2,7 +2,26 @@
+ # type alignment test #
+ #######################
+
+-AC_DEFUN([DBIND_CHECK_ALIGNOF],
++AC_DEFUN([DBIND_CHECK_ALIGNOF],[
++AC_CHECK_ALIGNOF($1,[
++#include <stdio.h>
++#include <stdlib.h>
++#define DBUS_API_SUBJECT_TO_CHANGE
++#include <dbus/dbus.h>
++typedef struct {char s1;} dbind_struct;
++typedef void *dbind_pointer;
++])
++
++dnl Note that we substitute for names like @DBIND_ALIGNOF_DBIND_STRUCT@, but
++dnl we #define names like ALIGNOF_DBIND_STRUCT in config.h!
++dnl
++AC_SUBST(translit(dbind_alignof_$1, [a-z *], [A-Z_P]),[$ac_cv_alignof_$1])
++
++])
++
++dnl The following does not work for cross-compilation.
++dnl
++AC_DEFUN([xDBIND_CHECK_ALIGNOF],
+ [changequote(<<, >>)dnl
+ dnl The name to #define.
+ define(<<AC_TYPE_NAME>>,