aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorAndre McCurdy <armccurdy@gmail.com>2016-01-18 13:33:51 -0800
committerRichard Purdie <richard.purdie@linuxfoundation.org>2016-01-20 09:20:05 +0000
commitb4bdbdd65dd9768209f453f1c2eacf1f7f78a998 (patch)
tree2707415fcd53491b675a950b228142e6f914761f
parent76583aa38ca0576306ce01b79167d63c18c5d135 (diff)
downloadopenembedded-core-contrib-b4bdbdd65dd9768209f453f1c2eacf1f7f78a998.tar.gz
strace: fix ARCH definition in tests/Makefile
TARGET_ARCH doesn't map to strace's ARCH variable, so we can't assign one from the other. Forcing the incorrect value via the make command line doesn't cause any problems with strace v4.10, but it will do for strace v4.11. Signed-off-by: Andre McCurdy <armccurdy@gmail.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org> Signed-off-by: Ross Burton <ross.burton@intel.com>
-rw-r--r--meta/recipes-devtools/strace/strace/define-OS-ARCH-in-tests-Makefile-am.patch26
-rw-r--r--meta/recipes-devtools/strace/strace_4.10.bb3
2 files changed, 28 insertions, 1 deletions
diff --git a/meta/recipes-devtools/strace/strace/define-OS-ARCH-in-tests-Makefile-am.patch b/meta/recipes-devtools/strace/strace/define-OS-ARCH-in-tests-Makefile-am.patch
new file mode 100644
index 0000000000..4b1bb26bb3
--- /dev/null
+++ b/meta/recipes-devtools/strace/strace/define-OS-ARCH-in-tests-Makefile-am.patch
@@ -0,0 +1,26 @@
+Ensure that OS and ARCH are defined in tests/Makefile.am
+
+For strace v4.10 this is a purely cosmetic fix, since the include
+paths derived from $(OS)/${ARCH) are never used. These variables are
+correctly defined by default in strace v4.11.
+
+Partial backport of upstream commit:
+
+ http://sourceforge.net/p/strace/code/ci/25c804ce42261b24b19d35c637bf2745c237ee07
+
+Upstream-Status: Backport
+
+Signed-off-by: Andre McCurdy <armccurdy@gmail.com>
+
+Index: strace-4.10/tests/Makefile.am
+===================================================================
+--- strace-4.10.orig/tests/Makefile.am
++++ strace-4.10/tests/Makefile.am
+@@ -1,5 +1,7 @@
+ # Automake input for strace tests.
+
++OS = linux
++ARCH = @arch@
+ AM_CFLAGS = $(WARN_CFLAGS)
+ AM_CPPFLAGS = -I$(top_builddir)/$(OS)/$(ARCH) \
+ -I$(top_srcdir)/$(OS)/$(ARCH) \
diff --git a/meta/recipes-devtools/strace/strace_4.10.bb b/meta/recipes-devtools/strace/strace_4.10.bb
index 0b2316b402..1b6474347a 100644
--- a/meta/recipes-devtools/strace/strace_4.10.bb
+++ b/meta/recipes-devtools/strace/strace_4.10.bb
@@ -12,6 +12,7 @@ SRC_URI = "${SOURCEFORGE_MIRROR}/strace/strace-${PV}.tar.xz \
file://run-ptest \
file://Include-sys-stat.h-for-S_I-macros.patch \
file://Include-linux-ioctl.h-for-_IOC_-macros.patch \
+ file://define-OS-ARCH-in-tests-Makefile-am.patch \
"
SRC_URI[md5sum] = "107a5be455493861189e9b57a3a51912"
@@ -37,7 +38,7 @@ do_install_append() {
}
do_compile_ptest() {
- oe_runmake -C ${TESTDIR} buildtest-TESTS OS=linux ARCH="${TARGET_ARCH}"
+ oe_runmake -C ${TESTDIR} buildtest-TESTS
}
do_install_ptest() {