aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorPaul Eggleton <paul.eggleton@linux.intel.com>2016-01-19 00:18:27 +1300
committerRichard Purdie <richard.purdie@linuxfoundation.org>2016-01-19 16:35:38 +0000
commit02570b1fc31c7f4e9643aea8365806089622c0e7 (patch)
treee5a7717b95f1b02152e8564ab48669470b7e0bb8
parentc58669fb0977f7f0cb79f252484d5c5ef0dfb7e4 (diff)
downloadopenembedded-core-contrib-02570b1fc31c7f4e9643aea8365806089622c0e7.tar.gz
recipetool: create: pick up boost macros in configure.ac
The presence of BOOST_REQUIRE or AX_BOOST.* indicates that boost is a dependency. Signed-off-by: Paul Eggleton <paul.eggleton@linux.intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
-rw-r--r--scripts/lib/recipetool/create_buildsys.py4
1 files changed, 4 insertions, 0 deletions
diff --git a/scripts/lib/recipetool/create_buildsys.py b/scripts/lib/recipetool/create_buildsys.py
index 7fedb2a917..544dae32db 100644
--- a/scripts/lib/recipetool/create_buildsys.py
+++ b/scripts/lib/recipetool/create_buildsys.py
@@ -294,6 +294,8 @@ class AutotoolsRecipeHandler(RecipeHandler):
unmappedlibs.append(lib)
elif keyword == 'AC_PATH_X':
deps.append('libx11')
+ elif keyword in ('AX_BOOST', 'BOOST_REQUIRE'):
+ deps.append('boost')
elif keyword == 'AC_INIT':
if extravalues is not None:
res = ac_init_re.match(value)
@@ -332,6 +334,8 @@ class AutotoolsRecipeHandler(RecipeHandler):
'AC_PATH_PROG',
'AC_CHECK_LIB',
'AC_PATH_X',
+ 'AX_BOOST',
+ 'BOOST_REQUIRE',
'AC_INIT',
'AM_INIT_AUTOMAKE',
'define(',