aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorChen Qi <Qi.Chen@windriver.com>2014-08-27 22:28:23 -0400
committerChen Qi <Qi.Chen@windriver.com>2014-09-03 15:05:43 +0800
commitefb20c33277ba183b89990d36fa7baacb33dd8b7 (patch)
treed223b891641f8f44456e3ad559ded3a2cee1ca5a
parentcade0d4e5c28c9259a3424d2531ee27ace1a5dd0 (diff)
downloadopenembedded-core-contrib-efb20c33277ba183b89990d36fa7baacb33dd8b7.tar.gz
packagegroup-core-boot: conditionally rdepend on VIRTUAL-RUNTIME_initscripts
If we are building a systemd image with 'sysvinit' not in DISTRO_FEATURES, the initscripts should not be installed into the image, as they are useless. What's more, we as now support executing scripts under /etc/rcS.d, the boot time will be increased by these scripts as the systemd will try to translate them into temporary service files. These init scritps are actually needed only when 'sysvinit' is in DISTRO_FEATURES. Signed-off-by: Chen Qi <Qi.Chen@windriver.com>
-rw-r--r--meta/recipes-core/packagegroups/packagegroup-core-boot.bb2
1 files changed, 1 insertions, 1 deletions
diff --git a/meta/recipes-core/packagegroups/packagegroup-core-boot.bb b/meta/recipes-core/packagegroups/packagegroup-core-boot.bb
index 886c33435c..09f537372e 100644
--- a/meta/recipes-core/packagegroups/packagegroup-core-boot.bb
+++ b/meta/recipes-core/packagegroups/packagegroup-core-boot.bb
@@ -27,6 +27,7 @@ VIRTUAL-RUNTIME_keymaps ?= "keymaps"
SYSVINIT_SCRIPTS = "${@bb.utils.contains('MACHINE_FEATURES', 'rtc', 'busybox-hwclock', '', d)} \
modutils-initscripts \
init-ifupdown \
+ ${VIRTUAL-RUNTIME_initscripts} \
"
RDEPENDS_${PN} = "\
@@ -38,7 +39,6 @@ RDEPENDS_${PN} = "\
netbase \
${VIRTUAL-RUNTIME_login_manager} \
${VIRTUAL-RUNTIME_init_manager} \
- ${VIRTUAL-RUNTIME_initscripts} \
${VIRTUAL-RUNTIME_dev_manager} \
${VIRTUAL-RUNTIME_update-alternatives} \
${MACHINE_ESSENTIAL_EXTRA_RDEPENDS}"