aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorBruce Ashfield <bruce.ashfield@windriver.com>2014-08-31 22:33:44 -0400
committerRichard Purdie <richard.purdie@linuxfoundation.org>2014-09-01 14:34:28 +0100
commitef48de6a4c1454c6f6e2de8636277b374ee44b50 (patch)
tree35ea2de44c37d0e70632e9058e07671edbe5aa68
parent2ddfffe52720d1df70b04131eac553776da7bc73 (diff)
downloadopenembedded-core-contrib-ef48de6a4c1454c6f6e2de8636277b374ee44b50.tar.gz
linux-yocto: ensure that recipe specific defaults take precedence
In order to make KBRANCH assignments more flexible and easy to override the default in each recipe as changed to a conditional assignment. But the common include file, sets its own branch default to master. This results in the recipes not overriding KBRANCH and master always being used. By putting the include after the default assignment, we now get the proper default branch. Signed-off-by: Bruce Ashfield <bruce.ashfield@windriver.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
-rw-r--r--meta/recipes-kernel/linux/linux-yocto-rt_3.10.bb4
-rw-r--r--meta/recipes-kernel/linux/linux-yocto-rt_3.14.bb4
-rw-r--r--meta/recipes-kernel/linux/linux-yocto-tiny_3.10.bb3
-rw-r--r--meta/recipes-kernel/linux/linux-yocto-tiny_3.14.bb4
-rw-r--r--meta/recipes-kernel/linux/linux-yocto_3.10.bb4
-rw-r--r--meta/recipes-kernel/linux/linux-yocto_3.14.bb4
6 files changed, 12 insertions, 11 deletions
diff --git a/meta/recipes-kernel/linux/linux-yocto-rt_3.10.bb b/meta/recipes-kernel/linux/linux-yocto-rt_3.10.bb
index 80d8db0823..de405a54e3 100644
--- a/meta/recipes-kernel/linux/linux-yocto-rt_3.10.bb
+++ b/meta/recipes-kernel/linux/linux-yocto-rt_3.10.bb
@@ -1,8 +1,8 @@
-require recipes-kernel/linux/linux-yocto.inc
-
KBRANCH ?= "standard/preempt-rt/base"
KBRANCH_qemuppc ?= "standard/preempt-rt/qemuppc"
+require recipes-kernel/linux/linux-yocto.inc
+
SRCREV_machine ?= "c373b342af7bcbeda346df9598a5b1e9784d362f"
SRCREV_machine_qemuppc ?= "767da5a30782cc1bc6522cef8aa5fd8130ecc06c"
SRCREV_meta ?= "199943142f7e0a283240246ee6c02f4376b315f0"
diff --git a/meta/recipes-kernel/linux/linux-yocto-rt_3.14.bb b/meta/recipes-kernel/linux/linux-yocto-rt_3.14.bb
index 406004f760..3b80c5326a 100644
--- a/meta/recipes-kernel/linux/linux-yocto-rt_3.14.bb
+++ b/meta/recipes-kernel/linux/linux-yocto-rt_3.14.bb
@@ -1,8 +1,8 @@
-require recipes-kernel/linux/linux-yocto.inc
-
KBRANCH ?= "standard/preempt-rt/base"
KBRANCH_qemuppc ?= "standard/preempt-rt/qemuppc"
+require recipes-kernel/linux/linux-yocto.inc
+
SRCREV_machine ?= "12f9e966eb249c3bdcc935612e2a372e90bad950"
SRCREV_machine_qemuppc ?= "52ceb28926768c49f06db4e7e08d2226c2a473fd"
SRCREV_meta ?= "ccad961c4cb6be245ed198bd2c17c27ab33cfcd7"
diff --git a/meta/recipes-kernel/linux/linux-yocto-tiny_3.10.bb b/meta/recipes-kernel/linux/linux-yocto-tiny_3.10.bb
index a751d54117..76448e1ba0 100644
--- a/meta/recipes-kernel/linux/linux-yocto-tiny_3.10.bb
+++ b/meta/recipes-kernel/linux/linux-yocto-tiny_3.10.bb
@@ -1,6 +1,7 @@
+KBRANCH ?= "standard/tiny/base"
+
require recipes-kernel/linux/linux-yocto.inc
-KBRANCH ?= "standard/tiny/base"
LINUX_KERNEL_TYPE = "tiny"
KCONFIG_MODE = "--allnoconfig"
diff --git a/meta/recipes-kernel/linux/linux-yocto-tiny_3.14.bb b/meta/recipes-kernel/linux/linux-yocto-tiny_3.14.bb
index 2ab3e1c067..5580e445d2 100644
--- a/meta/recipes-kernel/linux/linux-yocto-tiny_3.14.bb
+++ b/meta/recipes-kernel/linux/linux-yocto-tiny_3.14.bb
@@ -1,9 +1,9 @@
-require recipes-kernel/linux/linux-yocto.inc
-
KBRANCH ?= "standard/tiny/base"
LINUX_KERNEL_TYPE = "tiny"
KCONFIG_MODE = "--allnoconfig"
+require recipes-kernel/linux/linux-yocto.inc
+
LINUX_VERSION ?= "3.14.17"
KMETA = "meta"
diff --git a/meta/recipes-kernel/linux/linux-yocto_3.10.bb b/meta/recipes-kernel/linux/linux-yocto_3.10.bb
index f2904b62a1..125ffe7e38 100644
--- a/meta/recipes-kernel/linux/linux-yocto_3.10.bb
+++ b/meta/recipes-kernel/linux/linux-yocto_3.10.bb
@@ -1,6 +1,6 @@
-require recipes-kernel/linux/linux-yocto.inc
+KBRANCH ?= "standard/base"
-KBRANCH = "standard/base"
+require recipes-kernel/linux/linux-yocto.inc
# board specific branches
KBRANCH_qemuarm ?= "standard/arm-versatile-926ejs"
diff --git a/meta/recipes-kernel/linux/linux-yocto_3.14.bb b/meta/recipes-kernel/linux/linux-yocto_3.14.bb
index 2024d8e495..e88e31a2ba 100644
--- a/meta/recipes-kernel/linux/linux-yocto_3.14.bb
+++ b/meta/recipes-kernel/linux/linux-yocto_3.14.bb
@@ -1,7 +1,7 @@
-require recipes-kernel/linux/linux-yocto.inc
-
KBRANCH ?= "standard/base"
+require recipes-kernel/linux/linux-yocto.inc
+
# board specific branches
KBRANCH_qemuarm ?= "standard/arm-versatile-926ejs"
KBRANCH_qemumips ?= "standard/mti-malta32"