aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorChen Qi <Qi.Chen@windriver.com>2014-08-27 22:05:03 -0400
committerChen Qi <Qi.Chen@windriver.com>2014-09-03 15:05:43 +0800
commit755a5a1c87c6e5c9425bf8de192fedc1c4573b34 (patch)
tree559e25afb5d8df575e9b57c2f22849b9d3e39222
parentb200b4ce97c513af94517d6f4f4ee8c1a7ef66a8 (diff)
downloadopenembedded-core-contrib-755a5a1c87c6e5c9425bf8de192fedc1c4573b34.tar.gz
v86d: mask fbsetup when necessary
When 'sysvinit' and 'systemd' are both in DISTRO_FEATURES, we need to prevent the init script from running via systemd. This is because that the functionality has been implemented internally in systemd. Signed-off-by: Chen Qi <Qi.Chen@windriver.com>
-rw-r--r--meta/recipes-bsp/v86d/v86d_0.1.10.bb10
1 files changed, 10 insertions, 0 deletions
diff --git a/meta/recipes-bsp/v86d/v86d_0.1.10.bb b/meta/recipes-bsp/v86d/v86d_0.1.10.bb
index 7ccb4ee30f..f50207212f 100644
--- a/meta/recipes-bsp/v86d/v86d_0.1.10.bb
+++ b/meta/recipes-bsp/v86d/v86d_0.1.10.bb
@@ -57,3 +57,13 @@ python __anonymous() {
}
inherit update-rc.d
+
+DEPENDS_append = " ${@bb.utils.contains('DISTRO_FEATURES','systemd','systemd-systemctl-native','',d)}"
+pkg_postinst_${PN} () {
+ if ${@bb.utils.contains('DISTRO_FEATURES','systemd sysvinit','true','false',d)}; then
+ if [ -n "$D" ]; then
+ OPTS="--root=$D"
+ fi
+ systemctl $OPTS mask fbsetup.service
+ fi
+}