aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorChen Qi <Qi.Chen@windriver.com>2014-11-28 04:57:40 -0500
committerChen Qi <Qi.Chen@windriver.com>2014-11-30 16:40:27 +0800
commitbe9bd4dce47519cdda188b81ed1ff78497083207 (patch)
tree7c5833dc0cb9d223f211bc9e8517b3b31d17b4ee
parent68ddb28a68ceb59cd1ed322c16143827ce1ac712 (diff)
downloadopenembedded-core-contrib-be9bd4dce47519cdda188b81ed1ff78497083207.tar.gz
libxslt: create wrapper to avoid host system referencing
By default, xsltproc from libxslt would use configuration files under /etc/xml. To avoid host system contamination, we create a wrapper for this command to make it use configuration files in the sysroot directory. Signed-off-by: Chen Qi <Qi.Chen@windriver.com>
-rw-r--r--meta/recipes-support/libxslt/libxslt_1.1.28.bb5
1 files changed, 5 insertions, 0 deletions
diff --git a/meta/recipes-support/libxslt/libxslt_1.1.28.bb b/meta/recipes-support/libxslt/libxslt_1.1.28.bb
index 0b2526dbee..ded883e457 100644
--- a/meta/recipes-support/libxslt/libxslt_1.1.28.bb
+++ b/meta/recipes-support/libxslt/libxslt_1.1.28.bb
@@ -35,6 +35,11 @@ RPROVIDES_${PN}-bin += "${PN}-utils"
RCONFLICTS_${PN}-bin += "${PN}-utils"
RREPLACES_${PN}-bin += "${PN}-utils"
+
+do_install_append_class-native () {
+ create_wrapper ${D}/${bindir}/xsltproc XML_CATALOG_FILES=${sysconfdir}/xml/catalog.xml
+}
+
FILES_${PN} += "${libdir}/libxslt-plugins"
FILES_${PN}-dev += "${libdir}/xsltConf.sh"