aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorJonathan Liu <net147@gmail.com>2015-03-18 13:37:21 +1100
committerRichard Purdie <richard.purdie@linuxfoundation.org>2015-03-20 23:51:25 +0000
commit294adc0907a359d9c0ad260823188145aab294ad (patch)
tree693119fcffe70281a0e201aa481077196b63d38b
parentddac4f3c1350c3a4e0ea4ae732de0689325d883f (diff)
downloadopenembedded-core-contrib-294adc0907a359d9c0ad260823188145aab294ad.tar.gz
systemd: set the location of binaries used by service files
Otherwise systemd uses AC_PROG_PATH and finds it in the sysroot or host system, which won't work on the target. [YOCTO #7408] Signed-off-by: Jonathan Liu <net147@gmail.com> Signed-off-by: Ross Burton <ross.burton@intel.com>
-rw-r--r--meta/recipes-core/systemd/systemd_219.bb6
1 files changed, 5 insertions, 1 deletions
diff --git a/meta/recipes-core/systemd/systemd_219.bb b/meta/recipes-core/systemd/systemd_219.bb
index 117a529492..31caa30345 100644
--- a/meta/recipes-core/systemd/systemd_219.bb
+++ b/meta/recipes-core/systemd/systemd_219.bb
@@ -88,7 +88,11 @@ PACKAGECONFIG[xkbcommon] = "--enable-xkbcommon,--disable-xkbcommon,libxkbcommon"
PACKAGECONFIG[iptc] = "--enable-libiptc,--disable-libiptc,iptables"
PACKAGECONFIG[ldconfig] = "--enable-ldconfig,--disable-ldconfig,,"
-CACHED_CONFIGUREVARS = "ac_cv_path_KILL=${base_bindir}/kill"
+CACHED_CONFIGUREVARS += "ac_cv_path_KILL=${base_bindir}/kill"
+CACHED_CONFIGUREVARS += "ac_cv_path_KMOD=${base_bindir}/kmod"
+CACHED_CONFIGUREVARS += "ac_cv_path_QUOTACHECK=${sbindir}/quotacheck"
+CACHED_CONFIGUREVARS += "ac_cv_path_QUOTAON=${sbindir}/quotaon"
+CACHED_CONFIGUREVARS += "ac_cv_path_SULOGIN=${base_sbindir}/sulogin"
# Helper variables to clarify locations. This mirrors the logic in systemd's
# build system.