aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorAndre McCurdy <armccurdy@gmail.com>2014-06-12 10:29:02 -0700
committerRichard Purdie <richard.purdie@linuxfoundation.org>2014-06-14 08:42:12 +0100
commitf8377e96b353f8cf4a5812fa14c1c0405f769096 (patch)
tree111d3c7ee6fe8e83b2c90856b912c3581aed251f
parentbef49e8e8bf0a7f900f4ad44c2cbb6dec1d5d180 (diff)
downloadopenembedded-core-contrib-f8377e96b353f8cf4a5812fa14c1c0405f769096.tar.gz
curl: control ipv6 support based on DISTRO feature
By default ipv6 is auto detected for native builds but disabled when cross compiling. This commit adds a PACKAGECONFIG option, unconditionally enabled for native and nativesdk builds and controlled by the ipv6 DISTRO feature for target builds. Signed-off-by: Andre McCurdy <armccurdy@gmail.com> Signed-off-by: Saul Wold <sgw@linux.intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
-rw-r--r--meta/recipes-support/curl/curl_7.36.0.bb6
1 files changed, 6 insertions, 0 deletions
diff --git a/meta/recipes-support/curl/curl_7.36.0.bb b/meta/recipes-support/curl/curl_7.36.0.bb
index 56eb1a25a0..54ea6d407f 100644
--- a/meta/recipes-support/curl/curl_7.36.0.bb
+++ b/meta/recipes-support/curl/curl_7.36.0.bb
@@ -40,6 +40,12 @@ CURLGNUTLS = " --with-gnutls=${STAGING_LIBDIR}/../ --without-ssl"
CURLGNUTLS_class-native = "--without-gnutls --with-ssl"
CURLGNUTLS_class-nativesdk = "--without-gnutls --without-ssl"
+PACKAGECONFIG ??= "${@bb.utils.contains("DISTRO_FEATURES", "ipv6", "ipv6", "", d)}"
+PACKAGECONFIG_class-native = "ipv6"
+PACKAGECONFIG_class-nativesdk = "ipv6"
+
+PACKAGECONFIG[ipv6] = "--enable-ipv6,--disable-ipv6,"
+
do_configure_prepend() {
sed -i s:OPT_GNUTLS/bin:OPT_GNUTLS:g ${S}/configure.ac
}