aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorOtavio Salvador <otavio@ossystems.com.br>2014-07-18 13:47:06 -0300
committerRichard Purdie <richard.purdie@linuxfoundation.org>2014-07-21 19:04:54 +0100
commit3af5ed10f93de6def9342f710f3c6b94219a4c7e (patch)
tree789c82092261000063e0fb13cd688bf76e6e4e2d
parent16dcc820af60f1a875c9b3b13b545a78124ddd7f (diff)
downloadopenembedded-core-contrib-3af5ed10f93de6def9342f710f3c6b94219a4c7e.tar.gz
alsa-tools: Disable use of GTK+ when not using X11
The GTK+3 does not provide support for DirectFB backend so we cannot enable GTK+ features of alsa-tools in this case; GTK+2 does not provide support for Wayland. This patch changes GTK+ support to be enabled only when X11 support is enabled. Signed-off-by: Otavio Salvador <otavio@ossystems.com.br> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
-rw-r--r--meta/recipes-multimedia/alsa/alsa-tools_1.0.27.bb6
1 files changed, 3 insertions, 3 deletions
diff --git a/meta/recipes-multimedia/alsa/alsa-tools_1.0.27.bb b/meta/recipes-multimedia/alsa/alsa-tools_1.0.27.bb
index 62d71eaacd..bca7170a28 100644
--- a/meta/recipes-multimedia/alsa/alsa-tools_1.0.27.bb
+++ b/meta/recipes-multimedia/alsa/alsa-tools_1.0.27.bb
@@ -11,8 +11,8 @@ LIC_FILES_CHKSUM = "file://hdsploader/COPYING;md5=94d55d512a9ba36caa9b7df079bae1
SRC_URI = "ftp://ftp.alsa-project.org/pub/tools/alsa-tools-${PV}.tar.bz2 \
file://mips_has_no_io_h.patch \
file://autotools.patch \
- ${@bb.utils.contains_any('DISTRO_FEATURES', 'x11 wayland directfb', '', \
- 'file://makefile_no_gtk.patch', d)}"
+ ${@bb.utils.contains('DISTRO_FEATURES', 'x11', '', \
+ 'file://makefile_no_gtk.patch', d)}"
SRC_URI[md5sum] = "1ea381d00a6069a98613aa7effa4cb51"
SRC_URI[sha256sum] = "6562611b5a6560712f109e09740a9d4fa47296b07ed9590cb44139c5f154ada2"
@@ -21,7 +21,7 @@ inherit autotools-brokensep pkgconfig
EXTRA_OEMAKE += "GITCOMPILE_ARGS='--host=${HOST_SYS} --build=${BUILD_SYS} --target=${TARGET_SYS} --with-libtool-sysroot=${STAGING_DIR_HOST} --prefix=${prefix}'"
-PACKAGECONFIG ??= "${@bb.utils.contains_any('DISTRO_FEATURES', 'x11 wayland directfb', 'gtk+', '', d)}"
+PACKAGECONFIG ??= "${@bb.utils.contains('DISTRO_FEATURES', 'x11', 'gtk+', '', d)}"
PACKAGECONFIG[gtk+] = ",,gtk+ gtk+3,"
# configure.ac/.in doesn't exist so force copy