aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorDave Lerner <dave.lerner@windriver.com>2015-08-17 14:55:56 -0500
committerRichard Purdie <richard.purdie@linuxfoundation.org>2015-08-19 17:57:52 +0100
commit98c4a3ffb8dca10739be600e8d6df7fb6aa4958f (patch)
treef57518e939ac3c0d1ae7f1ea2f9acb0f5ad917f0
parenta98f4aedb241aa4352e644b5ef7c275f467c0c48 (diff)
downloadopenembedded-core-contrib-98c4a3ffb8dca10739be600e8d6df7fb6aa4958f.tar.gz
valgrind: build ptests without optimizations
This commit changes the both CFLAGS and CXXFLAGS when building the valgrind ptest binaries by appending -O0, forcing no optimizations instead of the default -O2. For qemux86-64, this change results in FAIL/PASS ratio improvements from 149/394 to 58/485. It is evident that the expected result files were generated from regression tests binaries built without optimizations. [ YOCTO #8063 ] Signed-off-by: Dave Lerner <dave.lerner@windriver.com> Signed-off-by: Ross Burton <ross.burton@intel.com>
-rw-r--r--meta/recipes-devtools/valgrind/valgrind_3.10.1.bb2
1 files changed, 1 insertions, 1 deletions
diff --git a/meta/recipes-devtools/valgrind/valgrind_3.10.1.bb b/meta/recipes-devtools/valgrind/valgrind_3.10.1.bb
index 97d923d6f0..537d7c8b93 100644
--- a/meta/recipes-devtools/valgrind/valgrind_3.10.1.bb
+++ b/meta/recipes-devtools/valgrind/valgrind_3.10.1.bb
@@ -57,7 +57,7 @@ RRECOMMENDS_${PN} += "${TCLIBC}-dbg"
RDEPENDS_${PN}-ptest += " sed perl glibc-utils perl-module-file-glob"
do_compile_ptest() {
- oe_runmake check
+ oe_runmake check CFLAGS="${CFLAGS} -O0" CXXFLAGS="${CXXFLAGS} -O0"
}