aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorGary Thomas <gary@mlbassoc.com>2015-01-20 09:50:35 -0700
committerRichard Purdie <richard.purdie@linuxfoundation.org>2015-01-23 11:35:26 +0000
commit6ff3776bb7f1a7ba2fc641bfd9b8546c4bb02466 (patch)
tree4e3d7f13be486d419ab83054af0c9e62afcadb6c
parenteee108a6ce6237f8aa7ab10f78ea9b8f69c900a5 (diff)
downloadopenembedded-core-contrib-6ff3776bb7f1a7ba2fc641bfd9b8546c4bb02466.tar.gz
perl: Backport fix for bug #123591
This patch fixes a crash in perl when using formatted strings @... Signed-off-by: Gary Thomas <gary@mlbassoc.com> Signed-off-by: Ross Burton <ross.burton@intel.com>
-rw-r--r--meta/recipes-devtools/perl/perl-5.20.0/fix-FF_MORE-crash.patch21
-rw-r--r--meta/recipes-devtools/perl/perl_5.20.0.bb1
2 files changed, 22 insertions, 0 deletions
diff --git a/meta/recipes-devtools/perl/perl-5.20.0/fix-FF_MORE-crash.patch b/meta/recipes-devtools/perl/perl-5.20.0/fix-FF_MORE-crash.patch
new file mode 100644
index 0000000000..9ec041c833
--- /dev/null
+++ b/meta/recipes-devtools/perl/perl-5.20.0/fix-FF_MORE-crash.patch
@@ -0,0 +1,21 @@
+Upstream-Status: Backport
+Reference: https://rt.perl.org/Public/Bug/Display.html?id=123591
+ From 62db6ea5fed19611596cbc5fc0b8a4df2c604e58 Mon Sep 17 00:00:00 2001
+ From: Tony Cook <tony@develop-help.com>
+ Date: Mon, 19 Jan 2015 16:03:18 +1100
+ Subject: [PATCH 1/1] [perl #123538] always set chophere and itembytes at the same time
+
+ Previously this would crash in FF_MORE because chophere was still NULL.
+
+Signed-off-by: Gary Thomas <gary@mlbassoc.com>
+Index: perl-5.20.0/pp_ctl.c
+===================================================================
+--- perl-5.20.0.orig/pp_ctl.c
++++ perl-5.20.0/pp_ctl.c
+@@ -590,6 +590,7 @@ PP(pp_formline)
+ break;
+ }
+ itembytes = s - item;
++ chophere = s;
+ break;
+ }
diff --git a/meta/recipes-devtools/perl/perl_5.20.0.bb b/meta/recipes-devtools/perl/perl_5.20.0.bb
index c1766fc377..db65202ec8 100644
--- a/meta/recipes-devtools/perl/perl_5.20.0.bb
+++ b/meta/recipes-devtools/perl/perl_5.20.0.bb
@@ -63,6 +63,7 @@ SRC_URI += " \
file://fix_bad_rpath.patch \
file://perl-archlib-exp.patch \
file://dynaloaderhack.patch \
+ file://fix-FF_MORE-crash.patch \
\
\
file://config.sh \