aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorPetter Mabäcker <petter@technux.se>2015-01-06 22:22:21 +0100
committerRichard Purdie <richard.purdie@linuxfoundation.org>2015-01-23 11:35:25 +0000
commit3693b63c5d33a88591be818a942324954b12e076 (patch)
treed977ee3ef95b181a169bdde67869c4141eea525e
parentbeae29727427f5da2a2287f29b4344538e6c3f1d (diff)
downloadopenembedded-core-contrib-3693b63c5d33a88591be818a942324954b12e076.tar.gz
lsof: handle S in a proper way
Since lsof are doing two unpacks and S should be set to match the second unpack of an internal archive, we should let the build system know that we are aware of this. Solve this by temporarily set S like lsof are doing with SRC_URI. [YOCTO #5627] Signed-off-by: Petter Mabäcker <petter@technux.se>
-rw-r--r--meta/recipes-extended/lsof/lsof_4.88.bb7
1 files changed, 7 insertions, 0 deletions
diff --git a/meta/recipes-extended/lsof/lsof_4.88.bb b/meta/recipes-extended/lsof/lsof_4.88.bb
index a96b06eae7..0e49f9217c 100644
--- a/meta/recipes-extended/lsof/lsof_4.88.bb
+++ b/meta/recipes-extended/lsof/lsof_4.88.bb
@@ -15,9 +15,16 @@ S = "${WORKDIR}/lsof_${PV}_src"
LIC_FILES_CHKSUM = "file://${S}/00README;beginline=645;endline=679;md5=964df275d26429ba3b39dbb9f205172a"
python do_unpack () {
+ # temporarily change S for unpack
+ # of lsof_${PV}
+ s = d.getVar('S')
+ d.setVar('S', '${WORKDIR}/lsof_${PV}')
bb.build.exec_func('base_do_unpack', d)
+ # temporarily change SRC_URI for unpack
+ # of lsof_${PV}_src
src_uri = d.getVar('SRC_URI')
d.setVar('SRC_URI', '${LOCALSRC}')
+ d.setVar('S', s)
bb.build.exec_func('base_do_unpack', d)
d.setVar('SRC_URI', src_uri)
}