aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorDrew Moseley <drew_moseley@mentor.com>2014-06-02 20:23:36 -0400
committerRichard Purdie <richard.purdie@linuxfoundation.org>2014-06-06 09:17:15 +0100
commitd602264267f49bf72704b6c5ab1247b4027313bb (patch)
treeb5e727763589eb02fba0f7f0fc7310dc7ef189ea
parentd5a95dc8985a42bb7e50bc4e7dc6b012d711ff08 (diff)
downloadopenembedded-core-contrib-d602264267f49bf72704b6c5ab1247b4027313bb.tar.gz
mesa-demos: Build with system data files
Use the "--with-system-data-files" when configuring mesa-demos so that the data files in /usr/share/mesa-demos/ will be properly located at run time. Copy some additional data files into the target filesystem. Signed-off-by: Drew Moseley <drew_moseley@mentor.com> Signed-off-by: Saul Wold <sgw@linux.intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
-rw-r--r--meta/recipes-graphics/mesa/mesa-demos_8.1.0.bb11
1 files changed, 11 insertions, 0 deletions
diff --git a/meta/recipes-graphics/mesa/mesa-demos_8.1.0.bb b/meta/recipes-graphics/mesa/mesa-demos_8.1.0.bb
index 7cda19eb6f..972ead3478 100644
--- a/meta/recipes-graphics/mesa/mesa-demos_8.1.0.bb
+++ b/meta/recipes-graphics/mesa/mesa-demos_8.1.0.bb
@@ -27,6 +27,8 @@ PACKAGECONFIG ?= "drm osmesa freetype2 gbm egl gles1 gles2 \
# The Wayland code doesn't work with Wayland 1.0, so disable it for now
#${@bb.utils.contains('DISTRO_FEATURES', 'wayland', 'wayland', '', d)}"
+EXTRA_OECONF = "--with-system-data-files"
+
PACKAGECONFIG[drm] = "--enable-libdrm,--disable-libdrm,libdrm"
PACKAGECONFIG[egl] = "--enable-egl,--disable-egl,virtual/egl"
PACKAGECONFIG[freetype2] = "--enable-freetype2,--disable-freetype2,freetype"
@@ -38,3 +40,12 @@ PACKAGECONFIG[osmesa] = "--enable-osmesa,--disable-osmesa,"
PACKAGECONFIG[vg] = "--enable-vg,--disable-vg,virtual/libvg"
PACKAGECONFIG[wayland] = "--enable-wayland,--disable-wayland,virtual/libgl wayland"
PACKAGECONFIG[x11] = "--enable-x11,--disable-x11,virtual/libx11"
+
+do_install_append () {
+ install -m 0644 ${S}/src/perf/*.frag \
+ ${S}/src/perf/*.vert \
+ ${S}/src/glsl/*.frag \
+ ${S}/src/glsl/*.vert \
+ ${S}/src/glsl/*.geom \
+ ${S}/src/glsl/*.glsl ${D}${datadir}/${BPN}
+}