aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorBian Naimeng <biannm@cn.fujitsu.com>2015-03-02 19:34:48 +0800
committerRichard Purdie <richard.purdie@linuxfoundation.org>2015-03-09 16:00:15 +0000
commit704fd8f1efbd7fa9368cfe4f956abf24cd58664e (patch)
treea8daf70168ae1a13d9c724c56a3625eeb0109417
parente7375f73bd8052d012e35d4ebaee09a55417581f (diff)
downloadopenembedded-core-contrib-704fd8f1efbd7fa9368cfe4f956abf24cd58664e.tar.gz
gcc-source: fix bug to avoid building error.
gcc-source don't do do_package_write_rpm, so we should set PACKAGES = "" to avoid the building error if we want generate srpm, otherwise, we get the error as below. ERROR: Task do_deploy_archives in meta/recipes-devtools/gcc/gcc-source_4.9.bb \ depends upon non-existent task do_package_write_rpm in \ meta/recipes-devtools/gcc/gcc-source_4.9.bb Signed-off-by: Bian Naimeng <biannm@cn.fujitsu.com> Signed-off-by: Ross Burton <ross.burton@intel.com>
-rw-r--r--meta/recipes-devtools/gcc/gcc-source.inc1
1 files changed, 1 insertions, 0 deletions
diff --git a/meta/recipes-devtools/gcc/gcc-source.inc b/meta/recipes-devtools/gcc/gcc-source.inc
index 968830aa35..10e9285c44 100644
--- a/meta/recipes-devtools/gcc/gcc-source.inc
+++ b/meta/recipes-devtools/gcc/gcc-source.inc
@@ -19,6 +19,7 @@ STAMPCLEAN = "${STAMPS_DIR}/work-shared/gcc-[0-9]*-*"
INHIBIT_DEFAULT_DEPS = "1"
DEPENDS = ""
+PACKAGES = ""
python do_preconfigure () {
import subprocess