aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorHongxu Jia <hongxu.jia@windriver.com>2014-06-17 19:03:03 +0800
committerRichard Purdie <richard.purdie@linuxfoundation.org>2014-06-17 17:55:08 +0100
commit0710ed28e868d4fc4ca027afb3c7acfc899f9409 (patch)
tree87012e2f3557677af1558b528a8b53c0a167cdc6
parent44ad25519b8e290f9a98b88eeec52ba199e76431 (diff)
downloadopenembedded-core-contrib-0710ed28e868d4fc4ca027afb3c7acfc899f9409.tar.gz
ghostscript: fix sizeof(GX_COLOR_INDEX_TYPE) not equal to ARCH_SIZEOF_GX_COLOR_INDEX on mips
The commit: http://ghostscript.com/pipermail/gs-cvs/2014-February/017271.html newly added a 'compile time assert' on 9.14 that causes the build to fail if the sizeof(GX_COLOR_INDEX_TYPE) is not equal to ARCH_SIZEOF_GX_COLOR_INDEX. Disscuss on IRC: http://ghostscript.com/irclogs/2014/02/06.html The commit from OE-Core rev: 78a13ba170c1de6d7ef077854e3e34e18d17099f ... ghostscript: add pregenerated objarch for mipsel/mips64/mips64el ... has defined ARCH_SIZEOF_GX_COLOR_INDEX according to the type of archs, and assigned 4 for mips/mipsel (8 for others). The GX_COLOR_INDEX_TYPE was defined at do_configure time, which used large color index (with 8) by default. We should manually choose the opposite one (with 4) for mips/mipsel. Signed-off-by: Hongxu Jia <hongxu.jia@windriver.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
-rw-r--r--meta/recipes-extended/ghostscript/ghostscript_9.14.bb3
1 files changed, 3 insertions, 0 deletions
diff --git a/meta/recipes-extended/ghostscript/ghostscript_9.14.bb b/meta/recipes-extended/ghostscript/ghostscript_9.14.bb
index 73cebbc86a..e14e656b93 100644
--- a/meta/recipes-extended/ghostscript/ghostscript_9.14.bb
+++ b/meta/recipes-extended/ghostscript/ghostscript_9.14.bb
@@ -42,6 +42,9 @@ EXTRA_OECONF = "--without-x --with-system-libtiff --without-jbig2dec \
${@base_conditional('SITEINFO_ENDIANNESS', 'le', '--enable-little-endian', '--enable-big-endian', d)} \
"
+EXTRA_OECONF_append_mips = " --with-large_color_index=0"
+EXTRA_OECONF_append_mipsel = " --with-large_color_index=0"
+
# Explicity disable libtiff, fontconfig,
# freetype, cups for ghostscript-native
EXTRA_OECONF_class-native = "--without-x --with-system-libtiff=no \