aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRobert Yang <liezhi.yang@windriver.com>2015-04-14 02:04:43 -0700
committerRichard Purdie <richard.purdie@linuxfoundation.org>2015-04-21 07:19:06 +0100
commit1e9ccec936554c69ede04babee9955f25b296588 (patch)
treebd497087463615db2e624df24f52c5ebfc707d3e
parenteb972e9b4b4210fa1c35fc0fae0ada27264b2e66 (diff)
downloadopenembedded-core-contrib-1e9ccec936554c69ede04babee9955f25b296588.tar.gz
libgcc: remove libgcov-dev from PACKAGES
There should be only one dev and dbg package. Signed-off-by: Robert Yang <liezhi.yang@windriver.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
-rw-r--r--meta/recipes-core/packagegroups/packagegroup-core-standalone-sdk-target.bb1
-rw-r--r--meta/recipes-devtools/gcc/libgcc.inc5
2 files changed, 1 insertions, 5 deletions
diff --git a/meta/recipes-core/packagegroups/packagegroup-core-standalone-sdk-target.bb b/meta/recipes-core/packagegroups/packagegroup-core-standalone-sdk-target.bb
index 154a55cea2..5d1ce97c2c 100644
--- a/meta/recipes-core/packagegroups/packagegroup-core-standalone-sdk-target.bb
+++ b/meta/recipes-core/packagegroups/packagegroup-core-standalone-sdk-target.bb
@@ -7,7 +7,6 @@ inherit packagegroup
RDEPENDS_${PN} = "\
libgcc \
libgcc-dev \
- libgcov-dev \
libstdc++ \
libstdc++-dev \
${LIBC_DEPENDENCIES} \
diff --git a/meta/recipes-devtools/gcc/libgcc.inc b/meta/recipes-devtools/gcc/libgcc.inc
index 21cb8c1084..35432c793e 100644
--- a/meta/recipes-devtools/gcc/libgcc.inc
+++ b/meta/recipes-devtools/gcc/libgcc.inc
@@ -6,7 +6,6 @@ PACKAGES = "\
${PN} \
${PN}-dev \
${PN}-dbg \
- libgcov-dev \
"
# All libgcc source is marked with the exception.
@@ -26,10 +25,9 @@ FILES_${PN}-dev = "\
${libdir}/${TARGET_SYS}/${BINV}/n32 \
${libdir}/${TARGET_SYS}/${BINV}/libgcc* \
${@base_conditional('TARGET_SYS_NO_EXTENSION', '${TARGET_SYS}', '', '${libdir}/${TARGET_SYS_NO_EXTENSION}', d)} \
-"
-FILES_libgcov-dev = "\
${libdir}/${TARGET_SYS}/${BINV}/libgcov.a \
"
+
FILES_${PN}-dbg += "${base_libdir}/.debug/"
LIBGCCBUILDTREENAME = "gcc-build-internal-"
@@ -40,5 +38,4 @@ do_package_write_deb[depends] += "virtual/${MLPREFIX}libc:do_packagedata"
do_package_write_rpm[depends] += "virtual/${MLPREFIX}libc:do_packagedata"
INSANE_SKIP_${PN}-dev = "staticdev"
-INSANE_SKIP_${MLPREFIX}libgcov-dev = "staticdev"